Issues with recording

A while back, I switched audacity to record sounds from my computer. Recently I tried to switch back to have it record from a microphone again, but for some reason audacity won’t recognize the mic. I’ve already checked to make sure microsoft doesn’t have my mic turned off. Any pointers?

using version 2.2.1 on windows 10 OS

Look in the Windows Sound Control Panel and check that the device is responding to the mic (there should be a green meter that responds to the input).
If that’s working, then in the device toolbar, set the “host” to MME and the recording device to the one that matches the device in the Windows sound control panel.

I’m guessing my mic’s just dead, because it’s not being recognized in the control panel either. oh well.

What sort of mic is it?

It’s a mic built into a logitech webcam. I’ve had it for 4+ years. The pc does still recognize the camera…

Have you checked that “Show Disabled Devices” and “Show Disconnected Devices” are both enabled in the Windows Sound Control Panel?
Have you tried rebooting the computer?

If you can’t get the mic to show up at all in the Windows Sound Control Panel, then I agree it is probably dead. Do you have another computer that you could test the webcam on?

Both are enabled, and rebooting didn’t fix it. I don’t have another computer to test it out on at the moment.