Issues w/Audacity 3.0.5 when recording


As of recent, I’ve had some issues using Audacity to record. I’m using version 3.0.5 on a Windows 10 laptop. When recording a track from my keyboard or other source, the cursor moves (barely) quite slowly, and instead of hearing the track via my headphones, I’m hearing a buzz-like noise instead. I can see that the track is recording, but when playing back, all I hear is the buzz (and the cursor still moves slowly…snail’s pace).

I’ve uninstalled and reinstalled the software, but the result is still the same. Is it my laptop or the software that’s the issue?

Thanks in advance for the help!

Most likely it is caused by an incorrect setting.

Open “Help menu > Diagnostics > Audiodevice info”
Press OK to save the information as a text file.

Then attach the text file to your reply

Also, ensure that “Software Playthrough” is NOT enabled (“Transport menu > Transport options” See:


I’m just now getting the chance to see your reply. Thank you so much!

It’s crazy that all of a sudden I’m having problems using the software, and I primarily use it as my quick & dirty tool when I need to get something done quickly without using my regular DAW. If you have any other suggestions, fire away.

deviceinfo.txt (4.45 KB)

The current version of Audacity is 3.1.3. It has quite a few bug fixes, so you should update - you can get it here:

What sort of keyboard? How is it connected to your computer?

Note that Audacity is NOT a MIDI recorder, and will not record MIDI keystrokes. To record from a MIDI-keyboard, you will have to record from its headphone output through an audio interface.

To answer Steve’s question, I’m connecting my Casio Privia piano via an audio interface to record music.
Jademan, I just downloaded the new version of Audacity last night. Haven’t tried it as of yet for fear of running into the same issue as previously mentioned, but I’ll give it a shot.

Thanks for the help!

What’s the audio interface?

Either my Presonus Audiobox USB or MXL Mic Mate.

In the “deviceinfo.txt” that you posted, there is no sign of a USB audio device.
Note that Audacity looks for available audio devices on launch. If you add or remove an audio device while Audacity is running, you need to tell Audacity to “Rescan Audio Devices” (near the bottom of the “Transport” menu).

My apologies…

I’ll hook up the interface and send another copy of the text file to you.
Thanks for noting the error on my end.

Hi Steve…
Here’s the text file w/ my Presonus Audiobox USB included. Note: You’ll have to scroll down a bit before you see it listed.

deviceinfo.txt (7.94 KB)

Have you tried plugging your headphones into the AudioBox and in Audacity’s Device Toolbar set the playback output to:

Device ID: 16
Device name: Speakers (3- AudioBox USB)
Host name: Windows WASAPI
Recording channels: 0
Playback channels: 2
Low Recording Latency: 0
Low Playback Latency: 0.003
High Recording Latency: 0
High Playback Latency: 0.01
Supported Rates:


What am I setting the playback output to? the Audiobox USB or the speakers on my laptop (Realtek Audio)

At the bottom of the deviceinfo.txt:

Selected recording device: 20 - Line (3- AudioBox USB)
Selected playback device> : 18 - > Speakers (Realtek(R) Audio)

Hey Steve…

I have the info pulled up, but I’m not able to make changes in the file. Am I missing something. Thanks in advance for your help!

You make the changes in the Device Toolbar.

Got it…Changes made.

Hi Steve…

I’m attaching a copy of the device log for you to check out. Haven’t tried to record anything yet, but I will.

deviceinfo.txt (6.45 KB)

Ok, I haven’t recorded anything, but I did try and upload an audio file to play. Still can’t get the software to play properly. Everything is set as it should be. Not sure what else to do.


Disregard my last post. I checked off software playthrough in the Transport Options dropdown menu, and NOW the track I imported is ACTUALLY playing!

Will try to record something next week. Thanks for all the help! I really appreciate it.