[Issue]Trim has been broken for ages

This has been broken for at least 3 years, and not working properly neither in Windows, nor in Linux versions.
Steps to reproduce:

  1. Make sure your microphone is connected, open a new project in Audacity.
  2. Press record button, wait a little for a few seconds of silence, say anything, wait in silence again, stop the recording.
  3. Now without saving anything, using your mouse select only your record voice, then use Trim to strip off silence before and after your voice.
  4. Now use Export to export a .wav file.
    In the resulting file, the leading silence is still present, while it should not.

That’s because in Import/Export Preferences you have the setting for “Ignore blank space at the beginning” set to off (this is the default setting).

So just go to Import/Export Preferences and check it “on”

See: https://manual.audacityteam.org/man/import_export_preferences.html

Peter.

An alternative solution is to use the Clip-handle drag-bar to drag the clip back to start at T=0 - and then make your Export.

Peter.