iShowU multi-output device not working with Audacity

Hi!

I’ve followed the directions specified on the wiki to use iShowU to record computer audio in Audacity, including creating a multi-output device. In Audacity, I have the multi-output device selected for the playback, and iShowU as the input. However, when I record, there’s only silence. What am I missing?

Audacity, I have the multi-output device selected for the playback

Yes, but Audacity will only output stereo (2 channel) or mono (1 channel) no matter how may devices you have selected.

What is the job? We get lost in a blizzard of connection info. What is the actual task. Why are we doing this?

Koz

I’m trying to record the sound from my computer. From a stream, for example.

Are you on a Mac? You shouldn’t leave out all that information when you create your forum account. We’re just going to have to ask you for it anyway.

I use iShowU on two different Macs and it works very well. Do you need those instructions?

Koz

Apple > System Preferences > Sound > Output > iShowU Audio Capture.

This will kill your speakers or headphones because the Mac is playing to iShowU.

Audacity Microphone (recording) window > iShowU Audio Capture.

Right this second, if you play your web page and Record in Audacity, it should show you a bouncing sound meter and blue waves. It may be silent.

Stop Audacity.

Set the Audacity Speaker window to Built-in Output.
Audacity > Preferences > Recording > [X] Playthrough (select). Record in Audacity and you should be able to hear it, but it may be late. You won’t get proper lip sync, but you will get the sound track recorded.

Koz

I did that in two steps to avoid digging a technical hole all at once. Did it work? Which step failed?

Koz

For those still struggling to record sound on a Mac(Mojave), navigate to System Preferences>Security and Privacy and click the Privacy tab. Make sure that Audacity has permission to access the Microphone- the OS treats iShowU as a microphone input device.

MacOS 10.15.7, Audacity version 3.0.2

I have the same result as the original poster when following the Wiki instructions. When following the instructions in this thread, these steps:

Set the Audacity Speaker window to Built-in Output.
Audacity > Preferences > Recording > [X] Playthrough (select). Record in Audacity and you should be able to hear it, but it may be late. You won’t get >proper lip sync, but you will get the sound track recorded.

have no effect. I hear nothing.