Is it possible to change the scale on the vu meter?

Hi team, I’ve been using audacity for a long time, and something I’ve always done is move the playback level meter to a separate level so that it uses the entire screen and shows Full Scale. (normally I use the range scale - 84db)
[This on windows]. and without problem the scale was adjusted from -X to 0 in steps of 1 in 1.

But on linux I have never been able to do this, the scales if it fits but never shows a division with steps less than 3 by 3 [unless I use a scale of -48 or less]
Is there a way to change the scale [or font] so that it shows jumps in 1 by 1?

OS: Debian 11 x64 - KDE Plasma desktop [Testing Packages Enabled]
Audacitiy: comp: Jan 17 2022 Commit Id: ff6d67 of Wed Dec 22 16:35:36 2021 +0100
Tipo de compilación: CMake Compilación de distribución (nivel de debug 1), 64 bits
Compilador:GCC 11.2.0
-Tested on Flatpak, APT [debian Older DSFG available], Appimage -in all the behavior is the same [Current install: Flatpak]

Maybe your screen resolution isn’t high enough on your Linux machine.

It could be the case, but I use the same monitor and its native resolution of 1366x768 in both systems (Linux and windows) and in windows I had not had that detail with the bar,

stretching the bar to full scale takes up 2 monitors for me . [it keeps making me noisy that the 3 in 3 scale can be displayed without problem in half screen and only continue like this until there is a minimum size for 1 in 1 scale] [perhaps a step through 2-2 would be desirable]. Oh well.


– there is a small bug with the Flatpak version dropdown lists, but I already have a github issue open.
I found a way to “patch” it for those who might have the problem in the future, forcing the resolutions with xrandr, it’s not ideal but
it seems to force the resolution of 1600x900 on a 768 screen It looks acceptable, or for less it is possible to put a scale of -48db
1920x1080 fully fits the scale but is already too blurry to read.

charlie@Charlie-USTCDeb:~$ cvt 1600 900
# 1600x900 59.95 Hz (CVT 1.44M9) hsync: 55.99 kHz; pclk: 118.25 MHz
Modeline "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
charlie@Charlie-USTCDeb:~$ xrandr --newmode "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
charlie@Charlie-USTCDeb:~$ xrandr --addmode DP-1 "1600x900_60.00


so I don’t know if maybe it’s all… or is there any other option? :nerd:

The behaviour I see - on Kubuntu 20.04 with a 3840x2160 resolution display - is that I get steps of 1 when the playback meter is wide enough, or steps of 6. The transition is about where the 2-digit numbers would not fit any more.

The behaviour is identical for the recording meter and the playback meter. In the screenshot, the recording meter is just below the minimum width for -84dB scale.
Screenshot_20220305_141136.png
The behaviour probably depends on the font used, so is certain to be different between Windows and KDE desktop and Gnome/etc desktop even on the same hardware. I’m not aware of any way you can customise the font selection in the meters.

But it could be a good idea to jump to intervals of 2 rather than 3 or (in my case) 6, immediately.