Is Audacity, or is it wxWidgets, that is limited to 10.6

Last question for the day
As the subject says, is it Audacity, or is it actually wxWidgets that it uses, that is limited to 10.6.SDK ?

You mean when building on Mac OS X I presume?
I’m not certain (I’m very new to building on Mac) but I think that now we have updated WxWidgets it’s Audacity that is the limiting factor. Hopefully not for much longer though. Work is currently starting to update to C++11 and to use a later version of gcc in our automated Linux builds. I’m guessing that updating the OS X build environment will not be far behind - I know that at least one of our lead developers is keen to update to a more recent version of Xcode.

Cool . Yes, Mac 10.11.3 XCode 7.2 SDK 10.11 Thanks for the heads up. I asked because earlier today I had wxWidgets pretty much built on my box here. and the Audacity ran pretty much to completion, although it still looked for 10.6 for something or other.

I gave it away at that point, as I have too much other work to do… the kind that pays the bills :slight_smile:

oh, and by the way, Audacity builds from the command line, but I haven’t managed to get right what ever it needs to build in the But I’m not worried, as I don’t have the time…
and in any case, now that the wizards are working on it… :slight_smile:

Thanks for the pointers so far though. Interesting exercise.

I think that’s mostly down to Apple. When I initially tried building on Mac, the Xcode GUI seemed very reluctant to work with anything other than its most recent SDK. Leland advised me to ignore the Xcode GUI and use the command line, and it’s worked nicely ever since :wink:

FWIW the Xcode 7.1 IDE builds Audacity OK for me on El Capitan. But you have to ignore its complaints about the 10.6 SDK being used, and not change any settings it suggests need changing.


It was decided at the time that Audacity should still support OS X 10.6, because about 15% of Macs at the time still used that OS.