Invalid Sample Rate

I tried to record my PC sound as I did under Windows 10 (1709) without problems .
But now with Windows 10 (1809) I get the error message “-9997 Invalid Sample Rate.”

I did install my PC completly new with 1809 because I got hoorible problemas after automated update from Windows 10 (1709) to 1803.

On Windows 10 (1809) I installed Audacity version 2.3.0.

My settings:

  • “Windows Wasapi”
  • “Lautsprecher (2- High Definition Audio-Gerät) …”
  • "2 (Stereo) Aufnahmekanäle) "
  • “Lautsprecher (2- High Definition Audio-Gerät) …”

I tried already a lot - but no success.

“Help menu > Diagnostics > Audio Device Info”
Save the info and attach the file to your reply.

see Diagnostics Audio Device in the Attachment.
My Project-Rate is 44100 Hz
Diagnostics_Audio-Device.txt (8.97 KB)

Try setting (in the device toolbar) the playback device to:
Kopfhörer (2- High Definition Audio-Gerät)
and the recording device to:
Kopfhörer (2- High Definition Audio-Gerät) (loopback)
and the “Project Rate” (lower left corner of the main Audacity window) to 44100.

Then start something playing so that it plays out through Kopfhörer.

Then try recording.

I tried to change the settings to “Kopfhörer”. But no success. The “Project Rate” was already 44100. But perhaps this time it is a problem of my hardware configuration, because I never could hear any sound with my headphones.I have connected external speakers at the green connector in the back of my computer. But when I connect a headphone at the green connector in the front, I cannot hear any sound. This has always been that way but I didnt need it. Until now - perhaps.