Invalid Sample Rate when attempting to record pc audio via Wasapi


I know this has been posted about a lot on here, but I must have read every single forum post and none of them have helped me.

I’m trying to record my PCs audio via loopback of my 18i20. Up until yesterday I was able to do this without a problem, however, I accidently unplugged my 18i20 and since plugging it back in I am getting either the error code 9997 or the “Error opening sound devices” messages.

I have checked, and rechecked multiple times and everything on my pc is set to 44100, the channels are all set to 2 and the bit rate the same across the board. The only thing I can see is my “Stereo mix realtek high definition” device is on 48000. However, all the drop down options are in 48000 with only varying changes to the bit rate.

Are you running windows PC
Go to taskbar, search, Control Panel, Sound, Make sure all your devices are enabled, or disable and re-enable them. Mixer 48000 probably OK… I think this is only for sharing…???
Are all you devices working for other audio applications…??
In control panel Untick the box so as to disable all enhancements

Hey thank you for the reply yeah Windows PC. So I could follow all that and everything that can be enabled is, all my other devices are working fine etc.

The only thing I could not find is the disable all enhancements you mentioned?

So I fixed it for those finding this post in the future.

Turns out the “Exclusive mode” options had to be turned off. They could be found in the advanced section of the speakers properties.

Good you got it working.
It was Advanced Mixer tick boxes I was thinking about. Mixer is in the recording tab. the same type of page as speakers. the bottom tick box Signal enhancements. I have it unticked in mixer and ticked in Speaker…??
Are you actually using mixer, I see you mention Loopback. Is that via an audio cable lineout to linein…?? Mixer would do it for you…??
Actually unticking these boxes doesn’t fix anything, it just helps isolate problems when troubleshooting. You may want enhancements on for improved sound and problem could be in the enhancement software setup …

This topic was automatically closed after 30 days. New replies are no longer allowed.