"Internal PortAudio error" when USB FX-unit is plugged

Hello, I just upgraded to 64-bit Windows 10 and I’m now having trouble getting my Pod X3 Live guitar effects unit to work via USB.
I’ve previously used Audacity to record my guitar but now when I start it up with the fx unit plugged in, I get the message message:
“Could not find any audio devices. You will not be able to play or record audio. Error: Internal Portaudio error”

However, Audacity starts and works normally whenever I don’t have the unit plugged in.
Transport > Rescan Audio Devices does nothing. Both input and output device dropout menus are empty in Audacity.
I’ve tried reinstalling drivers for the POD effects unit, ASIO and Realtek HD Audio to no avail.

Please help!
Happy to provide any additional details if needed.

Audacity can’t use ASIO unless you compiled Audacity yourself.

Audacity does not yet officially support Windows 10.

Have you installed the “Line 6 Monkey Installer Version 1.71 Released 7/23/15 for Windows 10” and restarted the computer? See http://uk.line6.com/software/ (change the dropdown to Windows 10 if necessary and click “Go”).


Thanks for the quick response. I doubt the question is of ASIO since I’ve used Audacity and Pod X3 Live without compiling anything in the past.
Yes I’ve the newest Line 6 software and it’s working. I tend to play guitar with my computer speakers, so I select “listen to this device” from “recording devices >> usb pod”, but ever since upgrading to Win10 I’m not getting any sound from that source either.

That sounds like a question you should ask of Line 6.

Does Audacity 2.0.2 or 2.0.3 recognise your X3: http://www.oldfoss.com/Audacity.html ?


Thanks. Yes it definitely looks like an issue with the Pod, but I already have a topic open on their forum with no response.
I downgraded from 2.1.1. to 2.0.2. and it the program starts fine without the error message and recognizes Pod, but when I press record with it selected:
“Error while opening sound device. Please check the input device settings and project sample rate.”

See if there is a solution here: http://manual.audacityteam.org/o/man/faq_errors.html#sound_device.

You may need to try a different Audio Host in Audacity or match sample rates in Audacity and Windows.


Thank you. Tried fumbling with the sampling rates etc, none of this helped. :frowning:

44100 Hz may have the best chance of working. If you choose MME host in Audacity with 44100 Hz project rate, stereo recording, Default Format in Windows Sound must be 44100 Hz stereo for Line 6 (for playback as well as recording if you play to this Line 6 device).

If you choose Windows DirectSound host in Audacity, put a check mark (tick) in both “Exclusive Mode” boxes for Line 6 in Windows Sound (for both playback and recording).

Depending what you are recording, try turning off Transport > Software Playthrough and/or Transport > Overdub in the Audacity menu bar.

If no apps can record from Line 6 then you should keep complaining to Line 6.

If you upgraded to Windows 10 over the previous version of Windows there is a button in Settings to go back to your previous Windows version. You have one month from installing Windows 10 to do that.


I have the same problem with Windows 10 x64 and POD HD Desktop. I compiled Audacity with ASIO support and it seems to work well with versions less or equal to 2.0.3 (I can now record and playback as normal).

I also compiled the latest version of Audacity with ASIO support and it kind of works except that the “Initializing Audio” error prevents Audacity from enabling the POD ASIO option. I am still able to record via Focusrite USB 2.0 Audio Driver (my external sound card) this however makes Audacity record from all sound card channels at once, were only the S/PDIF channels (were I plugged in my POD) produce a recording.

The issue is most likely due to problems with the POD drivers as already pointed out.

Thanks for the information.

There is a specific problem with POD ASIO drivers: http://line6.com/support/page/kb/_/pod/pod-farm-asio-driver-incompatibility-with-windo-r751 however even Audacity compiled without ASIO support can’t see any devices with a Line 6 device connected.