Internal error at Sequence.cpp line 1828

Thank you for receiving my question.
I’ve just completed editing a playlist of wav files, and now receive this message :Internal error at Sequence.cpp line 1828.
Please inform the Audacity team at
I have saved the file’s aup.1 and data in dropbox, but when attempting to open from dropbox the same error message shows.
When the file was last open, all the waveforms were suddenly flat, with no sound, as though they were empty, but with song titles, order, and length of songs seemingly still intact.
How might I correct the situation?
Thank you.

I’ve just completed editing a playlist of wav files

Did you keep backups of the original WAV files?


I have them in Dropbox, but unsure where they’re located within audacity.

I think using DropBox as a production drive is not a good idea.

They would like you to think you can gracefully and transparently switch between DropBox and your local drives, but you can’t. There are rules, not the least of which being internet switching, rerouting, negotiating and delays, all problems your local drives don’t have.

I would restrict using DropBox to its original purpose of posting work for distribution and transmission to other machines.

Also, Audacity Projects can be “surprised” by unusual circumstances. Do all critical work in WAV (Microsoft) or at least have WAV copies available when you can’t open a Project.

the file’s aup.1 and data

I don’t recognize that structure. Which three-number Audacity are you using? Did you get it from here?

This is a normal Project.


Thank you for your guidance re: dropbox.

I will use your advice.

I downloaded Audacity from your official site. It is version 2.2.0.
It was a little unstable at first, but then very reliable.

The only commands I’ve used besides importing mp3 and mp4’s are “fade in”, “fade out”, “normalize”, "and the usual “cut”, “copy”, “paste”, and “time shift”.
When I saved it, it saved in “recent projects”, and once I was finished and went to “export as mp3”, the above error message began showing.

Is there a way to fix the issue, and if no, if I begin the project again, how can I prevent this from happening? The only thing I didn’t do was “render and mix” the files, as I was unsure whether I could do the entire project at once or if I was supposed to do it with every song pair as I went along the way.

With Thanks

Precisely which Audacity command caused that message to appear?

Full steps to reproduce would be even more helpful.


You mean for that specific project?
That will depend on whether you are able to locate the project AUP file and “_data” folder.
If you can find both of them, copy them both to your Desktop. If they are on dropbox, ensure that you allow time to be fully copied to your top before you proceed, then try opening the project from the Desktop copy.

From what’s written in previous posts, I’m not entirely sure what you have done, but it sounds like you may be trying to work directly from a network drive (remote storage on dropbox). Doing that is likely to cause problems due to high network traffic interfering with Audacity’s requirement for fast and reliable read/write access.

When working with a brand new (not yet saved) project, Audacity uses a temporary folder on the local machine to hold the project data, but once the project has been saved, Audacity uses the “_data” folder that was saved with the project. If that is on a network drive, then you are likely to have problems. To work with Audacity and dropbox, always save the project to your local drive, and then “copy” the AUP and “_data” folders to dropbox (I like to make a ZIP archive containing both the AUP and the _data folder, and then move the ZIP file to dropbox. That way I can be sure that the AUP and _data folder stay together).

When you want to work with a project that is on dropbox, copy the entire project from dropbox to your local hard drive. (If you saved it on dropbox as a ZIP archive, extract the ZIP file to your local drive). Then work on the project, ensuring that you open the copy that is on your local drive.

Export as mp3 was the command
Since then, even retrieving the file from “Open Recent” provides the same error message.

Thank you for your replies.
I’ve just done as suggested: drag and drop files from Dropbox to Desktop (they were not zipped) and attempted to open the files from Desktop: The same error message appears.

New information just in: This may be due to a bug in Audacity. I’ll hopefully have more information soon, so don’t trash that project yet.

I see that you are now using Audacity 2.2.0. Do you know which version of Audacity you originally used when making this project?

Encouraging news.
I downloaded Audacity for the first time three days ago. So am working on the same version the project was created in.
On a trial I successfully exported a shorter playlist to my docs no problem.
This just occurred yesterday (Wed aft PST).
With Thanks

  • I meant to say, I successfully exported a trial on Monday afternoon, and the error showed yesterday afternoon…*

Would it be possible for you to make the affected project available to us? If you don’t want to make it public, you could perhaps send me a link as a PM (private message) by clicking on the “PM” button below my name in the topic list.

and if the last link is insufficient data, these two links should be more complete. they are the wav files and the aup file

with thanks

I’ve sent a request for access to the download.

I’ll need the whole project, including all of the data and the AUP file to be able to do anything with it.

I trust you’ve been able to open the AUP file and data? If no, please let me know.

No, that link only gives me access to some of the data files.

The second batch of links are the most I haves. Thanks for trying. Might the possible error have been fixed?