installed ffmpeg library 2.2.2 yet cannot export as mp4

I installed ffmpeg library 2.2.2 for audacity, yet cannot export as mp4. I couldn’t find what audacity version i have x86 or x64, but i didn’t see x64 version of ffmpeg so i suppose only 32 bit exists. Looked at faq and did all steps right, i checked if library is visible in audacity and it already found that. No idea than why i can’t still export as mp4.

Thanks for answer!

Audacity for Windows is 32-bits.

You can go to Edit → Preferences → Library and you should see “FFmpeg Library Version F(55.33.100)…”

If it’s not installed, download and RUN [u]ffmpeg-win-2.2.2.exe[/u] to install the special Audacity version of FFmpeg.

That’s it, and you should be ready to go…

No idea than why i can’t still export as mp4.

Isn’t an audio-only MP4 an M4A? MP4 is a video format. Audacity exporting video formats is an on-going developers discussion. Maybe FFMpeg has a trick for this. My impression is you have to do something with the video settings so as not to produce odd-duck files.

Is this for YouTube submission? I still think you have to put something in that video hole. Audio-only submissions have a still or video freeze.


I am having the same issue. I have windows 10, and audacity version 2.3.2. I just downloaded the ffmpeg 2.2.2., and have many options for exporting files. I don’t see MP4 as option.

I’m looking to export an audio file, and client requires an MP4. I get the sense that it will be used along with video.

Will the exporting as MA4 suffice?

Am I missing the export as MP4 option?


The current version of Audacity is 2.4.2:

In Audacity 2.4.2
“File menu > Export > Export Audio”
then select the required format.

MP4 is really a video format (
Typically the audio stream in an MP4 is AAC format.

Probably yes - In Audacity 2.4.2 it is “M4A (AAC) Files (FFmpeg)” and the default file extension is “.m4a”

If your player requires the file extension to be “.mp4”, then include that in the file name to override the default “.m4a” (Audacity may warn you that you are using an unexpected file extension).