Installed 2.03 now no sound from other applications [SOLVED]

Daft question but I can’t see the answer anywhere in FAQ or the forum.
Computer has realtek HD audio running vista 32bit - sound has always worked fine but since I installed 2.03 sound only now works in Audacity all other applications are dead as far as sound is concerned.
So itunes, windows media player, utube videos, even all system sounds now produce no sound.
I know the realtec side of things is ok because the realtec audio manager plays sound through all speakers and Audacity works.
What has installing Audacity done and how do I correct it?
I’ve tried re-installing the realtek HD audio drivers but this has not changed anything
Suggestions very welcome.

You’ve not said that you’ve done so, but every time I have come across this issue on Windows has been because a USB audio device has been connected. If this is the case, then the answer is here:

Thanks for the suggestion but there have been no changes to the connected audio equipment.
I have however used a usb stick so I’ll have a look at your link.

I rarely use Windows, but I seem to recall there being some sort of an “exclusive mode” option in Windows Sound Control Panel.

Thanks for the solution contained in the link, other programmes are now giving sound.
I don’t understand why installing Audacity creates this problem especially as I only connected a usb stick.
Perhaps you could mark my post as solved - I cannot see any way to edit my earlier posts.

It is Windows that creates the problem by changing the default playback device to the USB stick (even if it cannot play audio).

At least on Windows 7, if you make the built-in sound device the default playback device then remove the USB stick, then next time you plug the stick in, Windows will remember its non-default status and not make it the default playback device.