Inputting third- and fourth-level keys in labels


As reported on the Keyboard Preferences page of the Audacity manual,

ALTGR or Right ALT […] on Windows keyboards […] sends a combined CTRL + ALT modifier and can thus be used as an alternative to call any binding that includes CTRL + ALT

This behavior makes it impossible to input third- and fourth-level keys in labels, which is especially necessary for international users and for transcription purposes. In my opinion, Audacity should either do away with this equivalence between ALTGR and CTRL + ALT or make it a customizable preference.

I was going to report this as a bug to the developers, but then I thought that, before bothering them, I’d better come here and make sure that this is standard Audacity behavior and not just a problem in my own setup.

How to reproduce the bug (if you’d like to help me make sure):

  1. in your operating system’s preferences, select a layout with third- and fourth-level keys (such as the Italian layout);
  2. open Audacity, create a label;
  3. type any third- or fourth-level key into the label (for example, if you’ve selected the Italian layout, type ALTGR + the key immediately right of P, which would normally give you a square bracket);
  4. behold the total absence of output.

Thank you very much!

My data:
Lubuntu Linux 15.10
Audacity 2.1.2, coming from this PPA

P.S.: It can be done in the labels editor, but that’s no solution if you need (as I do) to be able to type those special characters as you listen, in the main interface, as part of a transcription workflow.

As a data point, on my Windows systems with English QWERTY layout, I can’t use ALT GR to type special characters in any applications I tried, so have to use CTRL + ALT. But CTRL + ALT + 4 does type the € symbol in Audacity labels, if that shortcut is not allocated in Keyboard Preferences.

Yes in Ubuntu 14.04 I can replicate your problem - even in English, I can use ALT GR + 4 to type the € symbol in text documents, but not in labels.

Probably there will be resistance to doing away with the ALT GR usage altogether, so it may have to be an option. Having to use a three-finger shortcut repeatedly rather than a two-finger shortcut could get wearisome.

By the way, on Ubuntu you can set an additional “alternative characters” key to use instead of ALT GR - see - but that key does not work in Audacity labels either in English QWERTY (even choosing CAPSLOCK as the alternative, which I would expect to work).


Dear Gale Andrews,
thank you very much for taking the time to confirm this. Now I can move on to reporting this as a bug, including a link to this topic for reference.

I was aware of that option in Ubuntu and I do, in fact, make use of it, but I didn’t mention it in order not to complicate the matter.

No need to report it to Audacity. Gale is the main man for tracking Audacity bugs, so he will have logged it already :wink:

I have not yet got round to putting it on Audacity Bugzilla. I’ve got to see what happens on Mac as well with a Windows keyboard (lots of people use Mac Minis with Windows keyboards), and whether it worked any differently on Linux in previous Audacity.

Assuming Artorius doesn’t get characters typed in labels either when setting up an “alternative characters” key, I do think that is a bug.

Adding an option to disable ALT GR as a shortcut seems to be an “enhancement” to me, not a bug. At least some ALT GR shortcuts can be created in Keyboard Preferences on Ubuntu and work correctly (I have not worked out yet why some can’t, or whether that is something to do with the built-in keyboard on my netbook).

Steve, is it standard on Linux for ALT GR to be used for third and fourth level characters and not as a CTRL + ALT substitute - that is, Debian behaves the same as Ubuntu?


Oops! In that case, I apologize, because I sent an email right after that post.

In short: no, I don’t: I use the left Windows key as an alternate third-level chooser, and that doesn’t work either, in Audacity.
(If I must be accurate: I use a somewhat elaborate custom multilingual setup obtained through the setxkbmap command).

If I may barge in: yes, it is.
I investigated the issue five years ago, when I had recently switched from Windows XP to Ubuntu Linux (which I later left for its lighter variant Lubuntu). If you’re interested in the matter (and you have time to waste reading my rather long-winded posts), you could have a look at this bug report that I filed, at the time, over at Launchpad (and this older one, too).

[Edited a sentence for clarity. (I’m not a native English speaker, and I’d used a misleading “yes, I do” instead of a more appropriate “no, I don’t”)].

[Unintentional double post. Please delete. I apologize].

In your comment 3 you referred to System>Preferences>Keyboard>Layouts>Options…:

  1. under “Key to choose 3rd level” check “Left Alt” and “Right Alt”,
  2. under “Alt/Win key behavior” select “Left Alt is swapped with left Win”.

I can’t find anything like those in Ubuntu 14.04. Have they been relegated to GNOME Tweak Tool or similar?


I’ve been using Lubuntu instead of Ubuntu for more than a couple of years, now, and I haven’t been keeping up with the evolution of Unity and GNOME 3, so I have no idea where those options have been moved to. In fact, in order to answer your question, I just installed the Unity session alongside my own, and I haven’t been able to find them, either: they seem to have been hidden from the user entirely.

Also, some time ago (perhaps a couple of years ago), there was an upstream change in xkb which removed “Left Alt is swapped with left Win” in favor of “Alt is swapped with Win”, so I had to also sacrifice the right Win key (and thus give up having a Super key entirely) in order to have my symmetric touch typing setup, which I achieve through a variation of the following command:

setxkbmap -option grp:lv3:lalt_switch,altwin:alt_win

This way, I have two ALTGR keys (or, more appropriately, two third level choosers) immediately flanking the space bar, whereas the two Windows keys become normal ALT keys.

So, I virtually have the following row:
Whereas my keyboard’s physical row is:

As I said, unfortunately it lacks the Super (that is the Windows) key, which is also useful, so it isn’t perfect, but at least it’s symmetric, and ergonomic for multilingual touch typing.