Inconsistent latency problem

I seem to be having an inconsistent problem with latency. SOmetimes I got it and sometimes I don’t, so I have to keep adjusting the latency setting on a case-by-cases basis, which you;re not supposed to have to do. WHat might be causing this?

Overdubbing works by, in essence, playing your beat track to you slightly early so that your live voice exactly matches and then it records the voice. Play them both back later and your voice and the unadvanced beats match, working around the internal computer delay (Recording Latency) problem. But only if that first step, the play-back-early part doesn’t ever change.

It will change. Normal computers are not fixed and that number will change slightly depending on how full your hard drive is and what else the computer is doing. This tiny change may be normally important over months, not song by song. If the computer is badly underpowered or badly overloaded, it will always need to be doing something important and different at the instant of recording.

Describe the computer. Are you on a G3 iBook with a full hard drive? Are you trying to do production with an external USB drive? You can do that with FireWire, but not USB.


It’s a MacBook, with the Intel chip, running OS 10.6.8. The hard drive is nowhere near being filled to capacity. It has a capacity of 499.76 GB and 433.66 GB is still available.

I can think of one other thing that could be lousing me up. Because the Mac has 4GB of memory, I have a habit of leaving a bunch of applications open that I use a lot.I’ve got five open right now. One of them was something I didn’t even realize was open. Could they be messing me up by grabbing CPU time? WOuld it be worthwhile quitting them all and seeing if that helps?

I just thought of something else that could potentially be causing problems. What I have right now is the instrumental section of a song, over which I’m trying to record the vocal track. As might be expected, I never get the vocal right in one take, so I have to do multiple takes. Each time I do a new take, I remove the track with the previous bad take. Since you can undo this action, I’m wondering if all those tracks I’m removing are being stored in memory somewhere and gumming up the works. Would it help if I saved the project after removing each of those tracks – or at least after I’ve done it several times?

If you think the applications are too “busy” then by all means close them. Also disconnect the network and if you have Time Machine running, disconnect the drive or temporarily close Time Machine. Stop AirPort. Do you have Virus Software? Many Macs don’t, but that can mess you up by trying to “inspect” everything you do. The supplier of our video Macs installed Norton and it caused no end of trouble until Norton eventually brought out a “Norton Removal Tool.” Suspend it.

You can run Go > Utilities > Activity monitor and see if the computer is running out of zot when you record.

Instead of starting a vocal track by deleting the old one, leave the old one there and mute it. Audacity will pile up 30 or 40 tracks in music preparation.

Here’s one out-there question. When you overdub, does your voice seem to be the same pitch as it was when you sung? If you play the track by itself (Solo or Mute), does it seem gritty or rough and not your normal smooth voice?


My voice sounds okay on the playback – just out of sync.

When you say to close Time Machine, is setting the on/off switch to off satisfactory? I don’t see a way to get rid of Time Machine altogether.

You can also just unmount and disconnect the Time Machine drive and it will idle until you plug it back in again.

“Oh, hey! I see you plugged your Time Machine drive back in. Do you want me to do a backup, please, please, please?”

You don’t want TM cranking through a massive backup while you’re trying to produce a song.

My voice sounds okay on the playback – just out of sync.

That’s the good news. The distorted pitch-change thing is a serious problem.

I’m not sure where to go from here. I’ve done this business on multiple Macs – I wrote the three hardware tutorials – and I’ve never had a machine drift far enough off sync to be audible once I set it.

I don’t depend on live voice timing to set Recording Latency. Both Steve and I use our hardware solutions, him with the foldback cable and me with the earbud jammed against the mic. Did you try either of those two techniques? It’s harder than you think to judge sync with a live voice.


We do get suspicious when the poster starts claiming symptoms that are highly unlikely. Koz

I did use the loop back cable technique and got a figure, but that didn’t seem to work in actual practice. At one point, I set the latency correction to zero and that was working when I played my keyboard.

Is it possible for the amount of latency to vary with the input device being used. It seemed that when I plugged my keyboard into the line input my Mac, I didn’t have any latency. Then when I went to overdub the vocals using the Mac’s built-in mic, I ran into trouble.

Yes. Each device can have different Recording Latency, but they’re not that far off from each other. I didn’t check the built-in microphone. I know that one takes a different pathway.

Do the hardware Recording Latency test multiple times one on top of the other and don’t change anything. All the passes should come out the same or reeeely close to each other and if you set it, they will come out in sync with the backing track. This is sooo much easier with a click track instead of trying to match up your voice.

Do it with the same microphone and exactly the same conditions. These settings will change if you plug in a USB microphone, a USB Mixer or an analog microphone (Windows) or analog sound mixer (Mac). They all take different processing.

A computer is not a Digital Audio Workstation.

I did use the loop back cable technique and got a figure, but that didn’t seem to work in actual practice.

It works if your normal sound pathway is analog. If your microphone is USB, then you’re stuck with the earbud and windscreen technique. I don’t remember actually saying that anywhere. I need to go back and check.


Okay, so the built-in mic probably does have a different latency setting than the line input – which seems to have none. I did the test with the click track and the loop back cable going from the line out to the line in jack… Maybe I should try the click track test and let the sound from the computer’s speaker get picked up y the built-in mic.

Of course, I could aways resign myself to just time-shifting the vocal track after the fact …

Aha, I seem to be the 2nd person in the world to have this problem. MacBook Pro 2012, OS X 10.8.5, using the built-in audio. Using a loopback cable the latency inconsistency is of the order of 50ms; using the built-in microphone it’s all over the place. Might be a couple of 10s of ms time, then 200ms the next.

All very odd! Anyone else hit this?

Had a random thought when I heard the usual click which the audio card seems to make when it powers up and down. I wonder if the time it takes for the card to power up is affecting the results?

As you gathered there probably isn’t much to be done about this apart from the obvious idea of shutting down as many other programs as possible and stopping Mac doing Time Machine backups, contacting network servers and whatever else it does from time to time.

To test your theory about initialisation, if you record for two seconds, stop, then immediately record again, do you hear the click when starting the second recording?

If so, might Macbooks turn off the audio subsystem after 20 seconds of inactivity be anything to do with this? If so, you could try Antipop linked to in that “makeuseof” Article.