In v2.4.2, can't read data from File History on external HD

I use Audacity v2.4.2 on a PC with Windows10, using Windows File History to back up files from my computer’s HD (C drive) to an external hard drive (F). For any Audacity project, File History copies both the .aup file and associated Data folder to a directory on the F drive paralleling the C drive directory. Big problems however:
– When I try to open the project directly from the F drive by clicking on the .aup file, no waveforms are recovered. I see error message: “Warning - Missing Audio Data Block File(s)…” The .aup file apparently can’t read the project data even though the project’s Data folder is in the same F drive directory. File History renames the .aup file for backup, and this (plus maybe other changes) seems to break the link between .aup file and associated Data folder.
– When I try to open the project by first starting Audacity and then using File>Open and clicking on the F drive’s .aup file, same result.
– When I copy the File History .aup file and associated Data Folder back from F drive to C drive (in a test directory different from where they originally lived on the C drive) and then try to open the project by clicking on the .aup file, same result.
This seems to make Windows File History backup useless for making recoverable backups of Audacity projects. (NOTE: Mp3 or wav files exported from Audacity projects on the C drive and then backed up by File History to the F drive apparently restore OK. )
What is your experience? Solutions? Are project files created by Audacity v3x subject to the same backup/restore problems?

In contrast, if I copy the .aup file and associated Data folder from their original C drive location to a test directory on the F drive and then try to open the project from that F drive .aup file, the project opens OK with waveforms seemingly intact. Does this match your experience?

More broadly, how do you suggest making recoverable project backups under Win10 or Win11 from Audacity project files?

Yes. As I recall, the .aup file must have EXACTLY the same name as the data directory (replacing .aup with _data). That is likely your issue, then. Also note that the _data directory must contain all of the little .au files with exactly the same names in exactly the same subdirectories.

No. The Audacity unitary project birthed 3.0.0. This removed the extra directories and all of the tiny .au files. Everything is now in one big unified .aup3 database project file. You can copy it, zip it up, transfer it between Mac and Windows, etc. When it becomes an .aup3 file again, Audacity can open it. :smiley:

However, it is strongly recommended to NOT open a .aup3 database project file while it resides on a networked drive. Unexpected breaks or delays in the communications chain can result in damage to the project. :frowning:

The name of the project is written into the AUP file, and that’s what tells Audacity where to find the audio data.

Example, this is a project called “mytest”.
The name of the project file is “mytest.aup” and the project _data folder is “mytest_data”.
This is the first few lines of “mytest.aup” viewed in a plain text editor:

<?xml version="1.0" standalone="no" ?>

<project xmlns=“” projname=> “mytest_data” > version=“1.3.0” audacityversion=“2.4.3-alpha-Nov 16 2022” sel0=“0.0000000000” sel1=“3.0000000000” vpos=“0” h=“0.0000000000” zoom=“590.3333333333” rate=“44100.0” snapto=“off” selectionformat=“hh:mm:ss + milliseconds” frequencyformat=“Hz” bandwidthformat=“octaves”>

Yes, as always. you are correct! That is 100% TRUE. I stand corrected. :smiley:


which in some cases MIGHT be easier to accomplish. However, I do not know at what version this also started working. :smiley: