Imports .mp3 as silence (2.0.4)[SOLVED]

Okay, so I’ve had this problem crop up recently where Audacity keeps importing .mp3s as silence - no waveform, no noise, no nothing. The only thing which is correct is the length of the track.

I’m running Audacity 2.0.4 on Win 7.

I had this problem with the older version of Audacity which I was working on previously, and I installed the 2.0.4 to try and correct the issue, but it hasn’t worked.

It was working fine last time I imported an mp3 file (28 August 2013).

Does anybody know how to fix this issue?


These files all open in Windows Media or other player?

no nothing.

You do get a flat blue line, right? It’s not “nothing.”


Yes, the files all open & play in Windows Media Player & the like.

And yes, I do get a flat blue line. What I meant was that I didn’t get the ordinary waveform which I usually get when I import .mp3s.
Apologies if that seemed dismiss or ignorant. :blush:

At the moment we don’t even know how to reproduce this issue.
Please describe step by step what we need to do to make this happen.

If you have a short MP3 that you know fails every time, post it here.


This sounds like Audacity cannot read its temporary folder.

Edit > Preferences, choose “Directories” on the left. Change the location of the temporary folder to a drive that is working and a folder that you have permission to write to.

If the problem persists, import the file, choose Help > Show Log… .

Choose Log > Save… and attach the log file.

See here for how to attach files: .


I open Audacity, and then I usually select the file and drag and drop it into Audacity from Windows Explorer. However, I still get the same issue when I go through the menus File → Import → Audio.

The first time I noticed this issue, it was on a short .mp3 (about 12 seconds, if memory serves) however more recently, it occurred with files which were longer (about an hour in length).

Fantastic! this seems to have corrected the issue! Thank you, so much! (I didn’t realise how much I used Audacity, until I couldn’t use it, and it was driving me spare!)

Thank you all so much for your help! You’ve made my day! :smiley: