Import wav problem

Hi i have funny problem & i really need your help because i have no idea how to fix that…

Here is the story:
I have decided to try to fix one movie audio so i choose audacity & install to c:pfaudacity

First i install version 1.2.6 & work in this version
I have ~90mb compressed wav file in 0x0055 MPEG-1 Layer 3 codec so i import this wav & i get 32-bit float src
i have note all timestamps etc & everything works great…

Then i want to have new features (selection toolbar) so i install version 2.0.6 to c:pfaudacity2 & i have both together, i need install also FFmpeg because i cant import wav anymore in new version.
At beginning my file also import as 32-bit float src in 2.0.6 i have almost done my job but after 2 days (i need to change something somewhere but i have no idea what…) & now my file import not as 32-bit float but 16-bit PCM, i set default sample format to 32 or even 24 but always, every freaking time i get 16-bit src… how i can change that to this 32-bit… program ignore this setting, i try everything & i have no idea what can i do more… when i import this file in 1.2.6 i get 32-bit but in all newer version i get max 16-bit…

Unfortunately all noted timestamps from 32-bit are competently different when i get 16-bit so i will need another 2 days to find all from begining:/

Audacity 1.2.6 is obsolete (has been for a long time) and is no longer supported. It is also known to have serious bug on “modern” versions of Windows (Vista and later).

I would recommend that you remove both versions of Audacity and then reinstall the current Audacity 2.0.6 using the default settings and the recommended installer, but look for the option (during the installation) to “reset preferences”. Select that option when it appears and continue the installation. On first launch, confirm that you wish to reset preferences.

To ensure that you have a genuine version of Audacity 2.0.6, you can download a fresh copy from here: Audacity ® | Download for Windows

With the default settings, Audacity will always import WAV files as 32 bit float.
Some compressed formats will import as 16 bit due to a limitation in the importer. Files that are imported as 16 bit may be easily converted to 32 bit float format by resetting the format in the track dropdown menu (“dropdown menu > Set sample format > 32 bit float” Audacity Manual )

Thanks, Steve. There is also an alternative solution that will save you having to manually convert the file to 32-bit - but there is probably no point in your case for only one file.

Obviously the PCM importer cannot open that file, but the built-in MP3 importer “should” do so. However the MP3 importer does not attempt the file, either due to a bug or there is a reason that happens. It’s been that way for a long time since 1.2.6.

As Steve suggests, that happens with FFmpeg for some formats because FFmpeg does not expand the audio to 32-bit (and again, the MP3 importer does not attempt the file whereas it should attempt the file before FFmpeg does).

In Edit > Preferences…, choose “Extended Import” on the left, then use the “Add new rule” button to add a rule for “*.wav” (without the quotes). In the “Importer order” window, drag “MP3 files” to the top of the list. Uncheck the “Attempt to use…” box. Now the MP3 importer should take the file and it will import at 32-bit resolution (and you wouldn’t need FFmpeg to import the file).



OMG dear Gale i normally <3 you… ahahahahahahaha, now when you write this:

i realize what i have done before…

When I change from 1.2.6 to 2.0.6 I just viewing new options in preferences & now I remember that in “Extended Import” (to be honest I didn’t really know what I’m doing I just clicking exactly like a monkey & I have create 4 rules “*”…

So basically I turn this on by mistake at beginning, ahahahahahahha:) This is really lucky - turn something on before I even know that this is what I need :smiley: THANKS I have spend 2 days to figure it out…

Now when I create the same rule “*” everything works perfect I have again 32-bit!

p.s. “.wav” or “wav” & “MP3 files” doesn’t work, only “*” & “WAV, AIFF…” or “MP3 files”


Oops, I did not hit the * had enough there, sorry - so I corrected that in my post. Yes “*.wav” (without quotes) .