Import Failed: This may be caused by an improper MP3 file


I have used Audacity successfully since version 2.4 but all of a sudden tonight when I try to open an MP3 file created by my Olympus voice recorder (which i have done over 50 times before) I am getting errors. I saw a new update was available for Audacity 3.0 so I have updated to that but I still get an error which now says “import failed. This may be caused by an improper MP3 file”.

I can listen to the recording no problem on my voice recorder and also on my windows 10 pc.

Attached are the support logs before I upgraded to 3.0.

How can I fix this problem? Why has it suddenly appeared?

Thank you in advance. (11.7 KB)

This is the last line in log.txt

17:40:33: Open(C:\Users\Carlisa\Documents\Audacity\David 22 Mar 21.MP3) succeeded




It still did not open the file. I just got the error.

I discovered there was an update released in the time between when I last used it and this time about 10 days
I saw that others were complaining about the same thing.

I am unsure how to proceed.


I am unsure how to proceed.


It’s mid morning Britain and that’s where most of the program daddies live.

We should also remember this is a forum. Users helping each other. Not a help desk.


There were notes a while back about how deformed an MP3 had to be before Audacity would reject it.

MP3’s full family name is MPEG-1, Layer 3. It’s the sound channel to a video format.

Until recently, Fraunhofer-Gesellschaft would collect royalties from any one creating an MP3 sound file. That’s why until recently, Audacity couldn’t create MP3 files by itself. Audacity is free and MP3 isn’t. I would not be shocked to find some manufacturers danced around the proper format to avoid paying those royalties.


Do you still have any of those 50 files that opened successfully before? If so, do they still open in Audacity?

I have just had a chance to try this now and yes they do open and import successfully. Seems somehow version 3 is blocking it as i haven’t made any change to the voice recorder settings and it hasn’t faulted. I recorded one on the 15th that worked fine then and still does and only a matter of days later on the 22nd March it failed to import.

I understand this is a helpdesk. I wish there was the ability to pay for access to support. I don’t mind paying for applications and support.

Audacity is such a fantastic application. I give the developers full marks!.

Which version of Audacity are you testing with?


Sorry thought i had answered this. It said it had to be moderated and seems to have got lost.

I was using version 3.0.0.


I’m confused.

You wrote:

Are you saying that the MP3s that opened previously, will also open in Audacity 3.0.0?

If so, then that appears to contradict your next statement:

Well very odd. I just recorded another meeting today using the voice recorder and that opens fine in audacity 3.0.0 so I am rather confused now.