Immense lag and frequent crashing on Audacity 3.1.3 AppImage

I just downloaded Audacity 3.1.3 and before I could do anything, I noticed it took a long time to start up. I then tried to open a menu, and it wouldn’t open. I fullscreened it, the viewport would resize but not the elements. I decided to wait a little while, and then everything happened at once, but after that it froze again. I closed it and tried again, but this time it would happen again and crash with no error log or anything. I’m currently stuck.

OS: Arch Linux
DE: KDE* (X11)
Compositor: KWin
Audacity version: 3.1.3** (Latest)
Audacity directory: /home//Desktop/audacity-linux-3.1.3-x86_64.AppImage

*Note: This DE often breaks and has abnormally high CPU usage even though there were no issues showing up on the task manager, but everything else was running smoothly despite this.
**I have… another version of 3.1.3 that doesn’t exhibit this issue, i’m not sure exactly what that version’s from. I doubt it’s official, though (as it shows up in the start menu applications menu). It does have another issue that is entirely unrelated, however.

Is this one of the versions?
(that’s the official version from the Audacity team)

it may be the distro’s version, it could also be the flatpak version.