I think I might have a software problem.

I am on macOS Sierra v10.12.6. A few weeks ago I updated my old Audacity to the latest 2.1.3 version. Before this I had no problems with using previous Audacity versions at a basic level, I’m no expert. Whenever I needed to know how to do anything the Audacity online manual would show me how, which I found quite easy.

A week ago a friend asked me to do a simple edit, or rather join, a few individual tracks into one long one. I tried but as some “overlapped”, ( the sound at the end was as per the sound of the next track for a few seconds), I could not delete the parts that overlapped. Eventually I gave up as I was busy with other things. I returned to it today and I cannot find help in the manual. A simple editing on the first track, I needed to remove a long silence before I got to the audio on the track. No matter what I tried I could not remove the long lead in. In the past on previous versions of Audacity this was simple exercise. I could remove long silences, or even the shortest, with ease.

I suspect that my latest update may be defective.

Should I remove the present application and reinstall, or is there something I am missing?

I updated my old Audacity to the latest 2.1.3 version.

What were you using? If there’s too big a jump, you can get in trouble by trying to use the tools in the old method.

In Audacity 2.1.3, you can open each one of the sound files one above the other and then Tracks > Align Tracks > Align End To End (I think that’s the right one) and it will automatically push them so the end of the first starts the second. Then you can use the Time Shift Tool to fine tune the positions. It should be possible to drag-select the parts you don’t want and then Delete.

Isn’t that how yours works?


Can you not do what is shown on this manual page?

Please check that Snap To is off in the Selection Toolbar.

Re-installing Audacity will not help, so don’t bother with that.

– Bill

Thanks for the response and the advice.

Yes I tried what you said. Unfortunately, even that didn’t work. I shut down Audacity and re-opened the applications, it worked for a while then some other problems started. Totally unrelated to the previous set of simple “malfunctions”.

I thought the best was to delete the present Audacity application and reinstalled. This seemed to solve my problem.

I must have picked up a “gremlin” in the original update. The reinstall worked.

I completed the exercise I had problems with; being able to remove the overlaps i.e. the exact same audio for the last few seconds of the track being the same as the first few seconds of the next track.

All in all, problem solved.

Thanks again for your advice, I shall keep this in mind for future use.