I need to compile 2.0 - but failed at first hurdle

I want to record multiple channels (4), so (it seems) I have to (for the first time in my life) compile a program ;-(!!

I found this page: https://audacity.googlecode.com/svn/audacity-src/trunk/win/compile.txt
which hopefully tells me what to do (accept that its says it’s for 2.0.0 alpha, but latest version seems to be 2.0.6)

But where is the source code for 2.0.6? (I’m on Win XP SP3)
This page: Redirecting to: https://www.audacityteam.org/download says go here: Redirecting to: https://audacity.gitbook.io/dev then here: Google Code Archive - Long-term storage for Google Code Project Hosting.

And eventually here: Google Code Archive - Long-term storage for Google Code Project Hosting.
Which says:

Use this command to anonymously check out the latest project source code:

Non-members may check out a read-only working copy anonymously over HTTP.

svn checkout > http://audacity.googlecode.com/svn/audacity-src/trunk/ > audacity-read-only

My browser is Chrome v35.

I tried entering into the command line:
svn checkout http://audacity.googlecode.com/svn/audacity-src/trunk/ audacity-read-only
then when that didnt work:
http://audacity.googlecode.com/svn/audacity-src/trunk/ audacity-read-only

Didnt work either.

Where/how do I download the source?
Or could someone help me some other way please.

Thanks for any help.

PS I have a Phonic 12 connected by Firewire to provide the channels.

Or just use commercial software that supports ASIO out of the box.

No it says it’s for 2.1.0-alpha which is the upcoming release we’re working on.

To run an SVN command you need an SVN client. TortoiseSVN is the simplest, and it’s free.

Note that

svn checkout http://audacity.googlecode.com/svn/audacity-src/trunk/ audacity-read-only

will checkout the latest 2.1.0-alpha code. You may not want that because there are unfinshed features and at least one known unfixed crash.

So I would suggest instead:

svn checkout http://audacity.googlecode.com/svn/audacity-src/tags/Audacity_2_0_6 audacity-read-only

which gets you the source code for 2.0.6 release.

Do you mean this http://www.phonic.com/en/helix-board-12-plus.html? If so are you updated with the firmware and drivers from https://phonic.app.box.com/shared/vd668kal7p/1/51402793 and have you already tried to see if you have multiple channels or a “Multi” device that you can choose in Audacity?


Thanks for your info.

I would like to stay with Audacity, as I’ve used and liked it for several years.

I’ve just tried to install TortoiseSVN, but it give the message.

…You must install a Windows service pack that contains a newer version of the Windows Installer service.

I’m on Win XP SP3 - and there isnt a newer SP is there?

Is there somewhere I can ftp the source from?

If you want to compile apps you’ll need to get used to using your favourite search engine :wink:

According to FAQ · TortoiseSVN, TortoiseSVN requires at least version 3 of the MSI installer. XP SP3 supports version 4.5 of the MSI installer, so try downloading and installing that from http://www.microsoft.com/en-us/download/details.aspx?id=8483.


Please see the thread right below yours posted by cmjone.