I dont want to record audio playback


Whenever I record in Audacity, it also records the playback. I just want a clean recording of my bass, without the music being recorded aswell.

Any ideas on how to accomplish this?

Yours sincerely,

That’s what happens when you try to record your instrument with the Audacity settings to record internet audio. Audacity has to be set to record from where ever you have your bass plugged in.

Set that in Device Toolbar.


You Do Not want Stereo-Mix or What-U-Hear. That’s what’s giving you the sound you have now.

See if any of this is helpful.



Hi Koz,

My bass is plugged into the amp, using DI to a mixer and the mixer sends a signal to my laptop. The Recording ‘name’ in Device Toolbar is called Line (USB Audio Codec). It doesn’t say Stereo Mix or whatever.

It even re-records the generated clicktrack in Audacity.

Yours sincerely,

Audacity > Edit > Preferences > Recording: [_] Overdub… (de-select)

I see that comes pre-selected in new Audacity installs.


Sorry. Falling asleep. You can’t de-select that because you are actually overdubbing.

When you playback your new track, Audacity will play everything that’s selected. Click MUTE on all the tracks you don’t want to listen to, or SOLO on the tracks you do.

Also, if you Export a sound file, click just above MUTE to select the track you want and File > Export Selected.


The fact is that it re-records the playalong channel on the overdub, and creating a slight delay.

Overdub should be the only thing selected in that panel.


It is.

If you think we’re both on here at the same time, keep refreshing your browser to see current postings.

I’m almost out of ideas… The delay or echo means it has to be a computer playback entering the system multiple times. The first sound is the intended one coming from the Audacity Overdub management system. The second one or echo is the mystery puppy.

It can’t be originating from the mixer because that would be in time with your live performance. One common mistake is leaving a microphone hot while you’re performing. That just gives you screwed up music, not echoes.

I gotta go back and read through that again. A Windows elf may drop in. I don’t think there is an Audacity setting which can cause this, particularly since they all seem to be correct.

Do you have Skype? Is it active while you’re recording?


Oh, there is one more.

Some fancy mixers have the ability to mix computer playback into the show. Normally, computer or guide tracks would only go to the monitor system so you can play to it, but more than one mixer has a fader so you can add the click and guide tracks to your live performance.

I’m runnin’ out.


I recorded a bit for you.

I played along with the first clicktrack, which got re-recorded at the same time as my bass. I’m playing in time with the re-recorded click, but it’s delayed compared to the original.

I do have Skype, which is opened but not in a conversation.

Test for Kozikowski.aup (3.63 KB)

As Koz suggested in his last post, you are likely sending what you are hearing back to Audacity for recording. There may be a “Mix” button or similar that needs releasing on the mixer.


An AUP is not a stand-alone sound file. It’s the manager for a Project.

You need both to make a show.

We normally need something like that as a clue to the problem, but I don’t think it’s going to help in this case. You’re perfectly clear to us what’s happening and in general, we have no idea why. A setting on the mixer is the best bet.

What is the mixer model number?


Skype and Audacity Do Not Get Along.

Skype aggressively sets its own sound adjustments and pathways. That’s the secret of its success. It works no matter what else the computer is doing.

I would close Skype and restart the computer. Make sure Skype didn’t start by itself. Run Audacity and see if the problem is still there.


Even when the mixer isn’t connected to my laptop, it records the playing audio.

I’m out. We had a similar, recent posting, but he had his mixer set wrong.

I have no idea. We should wait for another elf to take a stab at it. Did you close Skype and restart? Skype can create some very serious problems with sound routing.


So what recording device are you choosing then in Device Toolbar? What is the Line USB Audio CODEC - the mixer?

Please connect all devices, do Transport > Rescan Audio Devices at top of Audacity then post the device list from Help > Audio Device Info… at top right of Audacity.

Please tell us the make and model number of the mixer.


First of all I would like to apologize for my ignorance. I didn’t notice there was a second page already. That’s why my reply was late and weird.

The mixer that I have is a Behringer XENYX Q502USB Mixer. There is a button on it that says “to main mix”. If I turn it off, there is no re-recording, but then again I can’t hear a thing.

Closing skype helped reduce the volume of the re-recording significantly, but it’s still present.

When the mixer is not plugged in, and I use Stereo Mix to record, it also re-records the playalong.

The Line USB Audio Codec is indeed the mixer. Here is the list of Audio Device Info http://pastebin.com/UsGfQR7j.
Device ID #15 says Device name: Speakers (Realtek High Definition Audio) (loopback)
Device ID #17 says Device Name: Speakers (USB AUDIO CODEC) (loopback).
My guess is to turn off the loopback. Do you have any suggestions how?

I greatly appreciate your help and sorry for the late replies.


P.S. thanks for explaining how to send audiofiles, Kozikowski.

As you have it

Selected recording device: 18 - Lijn (USB AUDIO CODEC)
Selected playback device: 16 - Luidsprekers (USB AUDIO CODEC)

should work as long as you prevent the mixer sending the playback back to Audacity to be recorded.

Have you tried pressing “(USB/2-Trk) To Phones”? Someone in a prior Forum posting thought that would work.


When I toggle the “To Phones” button, it cuts the basssignal output to my phones, but the playalong gets boosted in volume by a little bit. It still records the playalong and the basssignal, but the latter of which gets a low-quality, high white-noise recording.