I don't know what i did but timeline does this when I play. How do I make it stop?

I don’t know what I pressed one day but whenever it’s playing, I get this. How do I get this to stop moving and just be a stable timeline?

iMac 10.13.6 High Sierra
Audacity 2.2.1

Click the “Pinned Recordhead/Playhead” button so that it shows a green triangle: https://manual.audacityteam.org/man/timeline.html#pinned

I’m stupid. Thank you.

I don’t think so …

It’s not exactly easily “discoverable” (and “discoverability” is normally one of our watchwords in the design of Audacity) to ascertain that clicking on that icon at the left of the Timeline toggles the play type from pinned to unpinned. The hovertext tooltips are somewhat limited, bland and not very helpful:

Click to pin

Click to unpin

These tooltips make no attempt to clarify what pinning/unpinning may do - I’ll see what I can do, if anything, to get those tooltips improved a little.

Once you know how it’s darn easy - but the app should be more helpful and not leave you trapped not knowing what to do.


I made an entry in our Wiki>Bear-traps page:

And I have opened a discussion on the Audacity Quality list about this.

As a minimum I’m hoping we can at least improve the tooltips - but we may be able to do more.


And you may be pleased to know that we’ve do a lot more than just fix the tooltips - a lot of discussion on the Quality email list ended up wiy=th our Release Manager and lead developer James made the changes.

  1. The icon at the left will no longer be an on/off button - instead clicking on it will show a context menu, on which one item is the head mode toggle. So much harder to accidentally turn on pinned head

  2. The right-click context menu for the Timeline has bee tidied up - a couple of entries have been moved to preferences and a new one added for head mode toggle

  3. The tooltip now says “Timeline Options”

These changes will be in the upcoming 2.4.0 release.