I don't even know what to title this but I need help

Okay, so I use Audacity to make song mashups. Obuad copied and pasted a portion of an acapella track I was working on when all of a sudden the program stops working and crashes. I had reopened the program to recover my project. I get a message saying something about there being “inconsistencies” with the recovery process or whatever. It then told me to use the HELP pulldown menu, do to DIAGNOSTICS, and then click on the “Show log…” options. Immediately after I follow all of those instructions THIS POPS UP and I haven’t the slightest idea what it means???

Which version of Windows?
Which version of Audacity? (look in “Help > About Audacity”)
What does “Obuad” mean?

Windows 10, the most current/up to date version. And I have no idea what that typo was. It was hella late at night lmao

The most recent version is “Audacity 2.3.1 RC03”, but I doubt that you have that version.
Look in “Help menu > About Audacity” for the version number.

If you have an earlier version than 2.3.0, I would suggest that you get the Audacity “EXE” installer via the Audacity website (Audacity ® | Download for Windows) and run the installer. During the installation process, select the option to “Reset Preferences”.

When you start Audacity, if you get asked if you want to recover one or more projects, select the option to recover them, then when the project(s) open, save them with new names.

If you see any other error messages, write down the message and include it in your reply.

This is similar to another wxwidgets debug message reported by five other users on the Forum:

We are at a bit of a loss as to how to deal with this, as we cannot reproduce it on any of our developer or QA PCs.

As with the related debug warning you should just be able to click through the Continue and Audacity should then work.

This is a debug message from the wxwidgets library that Audacity uses rather than from Audacity itself - but nonetheless a released application should not be showing debugging messages.


I have discussed this with our key developer - he asked me to log this on our bug-tracker:

Thanks for reporting this.


It would still be useful if you could tell us the exact version number of Audacity that this occurred with.

Here’s a similar incident with report attached. Happens every time on program launch. Windows 10 1809 Audacity 2.3.0. Similar to bugs 2074 and 2075. Haven’t tried updating to 2.3.2 so it might be fixed already. Don’t know.
Audacity_dbgrpt-6476-20190729T013343.zip (63.7 KB)

What is: “Desktop-h1251mr” ?

Another Windows 10 PC on the network. I know its picking up the effects from that one too. Never been an issue before now. They’re all disabled on this machine so only the local copies are enabled and used. Here is a screenshot I should have attached the first time. This was captured now (not when the report was created) but the message is the same.
Annotation 2019-07-29 064317.jpg

You’ve got permissions problems. Audacity is unable to save it’s settings, which is triggering an error message from wxWidgets. Are you the system administrator?

Yes. Its worked fine till maybe a month ago.


Did you install Audacity from the .EXE installer?
Were you logged in as “Anthony” when you installed it?
Are you logged in as “Anthony” when you see this problem?
Is “Anthony” a normal user account?

Yes I used the installer. Always have. Anthony is the only user account on the machine and yes of course is an administrator account. There’s really no obvious reason why Audacity wouldn’t have permission to write to the settings file. I’ll have to investigate this evening.

I cleared all the old settings, uninstalled Audacity 2.3.0, and installed v2.3.2. After manually migrating some settings, copying the old plugin settings file (not the plugin registry though) and importing keyboard shortcuts, I have it back like I like it and actually a bit improved. The old Audacity config file had been carried over from a long time ago (maybe 2.0.6?) And the plugin registry was cluttered with missing plugins, old obsolete plugins, and multiple versions of the same ones. It works perfectly now. I honestly think it was just time to clean out the clutter and start fresh again. Maybe always selecting to not reset the preferences when updating isn’t always the right answer (at least, not after 5 or 6 years😅).

Thanks for the update. Pleased to hear it’s now working.