I can't record

II have Windows 7. I have used Audacity for many years. Suddenly I cannot record. I can listen. When I hit Record all I get is a flat line and there is no sound on Playback. Something must be going in because the red/green bars at the top show it, but there is no wave form. I have download the program twice, but I get the same result. Before if I re-installed, it worked perfectly as soon as I turned the program on. I must be doing something wrong, but I have tried everything I can think of. I use it frequently and I hope someone can help me!

Bill K

I’m guessing that the waveform is present, but too small to see.
As a test, try recording and then apply the Amplify effect to the recording and see if the recording appears. If it does appear, then it will probably be horrible sound quality because the original recording level is far too low, but it will prove whether recording is actually working and then we can sort out the problem with the recording level.

What are you trying to record?