I can't record with Audacity on Windows 10

I recently bought a Windows 10 computer and installed the latest Audacity version on it.

However, I can’t record anything on it. WASAPI doesn’t work. When I push the “record” button, nothing is happening.

And as you understand, there’s no “Stereo Mix” available on Windows 10 either.

I’ve tried everything to adjust the settings on Windows 10 and tried everything on Audacity but nothing helps.

What can I do?

Please aswer the following additional questions:
what source do you record? external audio via usb? via audio cables? micro?
Or internal sounds like music on the internet, etc…?

Recording via WASAPI often does not start immediately. It waits until a sound is coming in.

First step is always to find a working combination of the four fields called “device toolbar”
1st Field:Audio Host
Each will change the following three fields.

2nd Field: Recording device
Here you should select your prefered recording source. If there is no entry, you have a problem with the driver of the source.

3rd Field
MONO or/and STEREO will be selectable depending on HOST and DEVICE you selected before.

hi im having the same issue with audacity…i recorded an lp the first side of the lp finided ok till the end the 2nd side recorded up to a point then stopped…im on windows 10 64 bits.i didn’t add anything new…this is a dell desktop inspiron…the computer is about 4 months old…i use the mm option