i cant record with an external mic?

hi, I have a dell inspiron 15 3521, and I am running a cisno bm 800 phantom mic, through and avid mbox mini, into the usb drive on the laptop

before, i use to have windows 8, when i first got the laptop, and i had absolutely no problems recording, with this same setup.
however, when i upgraded, or so i thought, to windows 10, i cannot record any quality sound, from the mic
i can hear myself in the heaphones perfectly fine, but when i record, and play it back, i have to turn the volume allll the way up, and it sounds very queit still, and very gargled, and distorted.
i also hardly see any level on the mic monitoring.

i have the mic enabled on the laptop settings, and i have the mic volume up on audacity, still cant figure out what im doing wrong
pleaseeee help
thank you

[EDIT] I missed the part where you said it sounds OK from the headphones…

Make sure you’ve selected the USB interface as your [u]Recording Device[/u]. It might not have the exact name of your interface, but it should say “USB… something”.

And, scratch on the mic-grill with your fingernail to make-sure the computer is picking-up the external mic, and not the mic built-into your laptop.

Announce as you go.


If you don’t know where your laptop’s microphone is, this is a dandy time to find out.


I know where the internal mic is… this is not the mic I want to use.
I have the usb mic selected, and enabled on both the laptop, and in audacity.
and I have the internal mic disabled.

I have the correct mic selected.
and the internal mic is disabled

yes, I hear myself through the correct (usb) mic.
but it does not record good sound at all.

and the dell audio, on the laptop does not recognize the mic

Are you singing or playing a musical instrument? You should disable the Windows voice processing. The settings are intended to help you speak to a conference or an on-line meeting. It hates music.


There may be others, but that’s a darn good place to start.


thank you, but still no help.
I should also state, when I open dell audio, and go into the microphone tab, it says to connect audio device, which is already connected…

I should also state, when I open dell audio, and go into the microphone tab, it says to connect audio device, which is already connected…

Have you downloaded the latest drivers for Windows 10? Most of these little USB audio interfaces are “class compliant” and work with the Microsoft-supplied drivers, but the Mbox may need drivers from Avid. (I only found drivers for the “3rd gen” Mbox so I don’t know what’s available if you have an older one.)

Have you tried another USB cable? Or, maybe the Mbox has died, or maybe it’s not Win10 compatible?