I can't listen to tracks while I record [SOLVED]

Audacity version 2.1.2
Windows 10

When I record something while I have a second track(that isn’t on mute), I can’t hear the track while I record, though I was previously able to.
This started happening after I plugged in a Blue Snowball mic, but I only plugged it in once, and then I stopped using it.

Check that the playback device setting in the device toolbar is set to the device that you wish to play back through.

I have it set on MME

By the way, I can listen to the music when I press play, but when I record it’s silent.
(I forgot to mention that)

MME is only the Audio Host. Steve meant the Playback Device (the last box on the right of Device Toolbar).

But from your description above, make sure Transport > Overdub has a tick (checkmark) by it. Click it if it doesn’t.


That’s the “host sound system”. The playback device setting is the last dropdown menu on the right end of the Device Toolbar. See: http://manual.audacityteam.org/man/device_toolbar.html

:slight_smile: That’s important.

Look in the Transport menu, near the bottom. Ensure that “overdub” is selected (enabled) and “software playthrough” is not selected (disabled).

Thanks, it’s working now. =)
Have a nice day! =D