I Can't Add Plug-Ins

(MacOS Mojave Version 10.14.4)

Hey, good afternoon :slight_smile:

I recently switched from Windows to Mac and when I downloaded Audacity and tried adding the plug-ins, I couldn’t, no matter how many ways I tried.
I even asked the Audacity subreddit. If any of you could help or even maybe hop on ‘TeamViewer’ and do it for me, it would be forever thankful.

Hope y’all having a good day.

What have you been trying?

Have you followed the instructions on this page?

– Bill

Hi, bill.

That and another method is what i have tried.
Since you are a staff member, maybe you could do it for me on TeamViewer? I would be very thankful

What kind of plug-in are you trying to install? Nyquist, Audio Unit, VST, LV2?

We are all volunteers here and we don’t do TeamViewer.

– Bill

VST i believe

It’s much easier for us to provide meaningful help if you provide full and detailed information, such as the name and version number of the plug-in and a link to it’s home page / documentation page.

My bad.
I was busy at the time I didn’t have time to log in to my Mac.
I tried installing LAPSDA and VST. They appear on the ‘Add Plug-Ins’ menu but when I try to enable them, it says they fail to register.

So what, exactly, are the names and version numbers of the plug-ins? Where did you get them? Does their documentation say they are compatible with Audacity and macOS 10.14? What, exactly, does the error message say?

– Bill

This is the error message:

Effect or Command at /Applications/Audacity.app/Contents/plug-ins/swh-plugins-mac-0-2/Archive/xfade_1915.so failed to register:

Could not load the library

Here are the links for what I tried downloading, which are promoted on the plug-ins area of Audacity’s site:
LV2: http://lv2plug.in

I found out that LADSPA is only for legacy MAC computers.

All the plug-ins I have downloaded are from Audacity’s official page.