I can't activate some plug ins

Hi guys my problem is that i can’t activate some plug ins others just work fine. For example when i try to enable Voxengo Oldskoolverb or Klanghelm DC1A i get a pop up message that says effect or command could not be registered. could not load the library. I don’t know what to do please help :neutral_face:

I checked the Voxengo website and Audacity is not listed as an officially supported host:

Compatible Windows and macOS plugin software: Cubase, Logic Pro, ProTools, Ableton Live, Reaper, OBS, Presonus Studio One, FL Studio, Cakewalk, Nuendo, WaveLab, GarageBand, Vegas, SoundForge, Audition, Samplitude, Digital Performer, Mixcraft, Bitwig Studio, Edius, others

That doesn’t mean it won’t work but you really “can’t complain” if it doesn’t. :wink:

I didn’t check the Klanghelm website.

Note that Audacity is a 32-bit application so 64-bit plug-ins won’t work, even if you have 64-bit Windows.

I know but i have a few other Voxengo plug ins on Audacity and a friend has the plug ins on Audacity so on his pc everything just works fine :neutral_face:

I have the same problem. None of my plugins will enable. They worked before on my PC and my laptop. Now they won’t. Win10.

Perhaps he has a different version of the plug-ins (most likely) or a different version of Audacity.



So I took a look at the Voxengo Oldskoolverb plugin. The download includes both 32- and 64-bit versions of the plugin. When you run their setup installation program it gives you the opportunity to install one or the other or both DLLs. If you select both, then, by default, the 32-bit version gets overwritten by the 64-bit version :astonished:, so it is important that you specify 32-bit and you de-select the 64-bit version.

The 32-bit version seems to run just fine on my Windows 10 machine.

Thanks to bitflipper on the cakewalk forum, you can easily look at a DLL file and determine if it is 32-bit or 64-bit:

Use a file-info tool such as the free Filealyzer (PE Header tab).

In my case, if I use Filealyzer on the 64-bit OldSkoolVerb.dll, it shows PE Header > Characteristics: 2022 = Executable, Large Address Aware, DLL
and the 32-bit OldSkoolVerb.dll (same name): PE Header > Characteristics: 2102 = Executable, 32-bit Machine Expected, DLL.

I hope this helps. :smiley:

Thank you, but it doesn’t help. The plugins worked before, on the same laptop and OS as now.

Since none of your plugins will enable, I assume you have tried deleting your pluginregistry.cfg and pluginsettings.cfg files?

BTW, when I do this, I always back them up first (or just rename them to …cfg.bak).

I hope this helps. :smiley:

I couldn’t find them, even after I tried reinstalling Audacity.

SInce you’ve been around a while, I deliberately did not give you the detail I would have given someone else. :wink:

the plugin cfg files are located under C:\Users<your name>\AppData\Roaming\audacity. AppData is a hidden directory. To be able to see AppData, go to File Explorer and select the View tab. Then check the box labelled “Hidden Items”.

I hope this helps. :smiley:

Fair enough. You didn’t want to be looking down on me. I have now found and dumped the two files. It worked.