I cannot get noise removal to get a sound profile

I am running XP SP3 … Audacity 2.03 (though I tried it on more than one version of Audacity and had the same issue) … installed from .exe …

I have some sound files that I got from some old records of my mother-in-laws but when I went to try to remove the excess noise from them I could not get it to give me a sound profile. I tried several different files, rebooting computer, using different version of Audacity, and selecting differing lengths of sound. When I push the button for get sound profile it just closes the window and when I reopen the window the numbers are still set on the default values. I have tried everything I can think of…

I’m running a tricore 3.0 processor with 4gb of ram so I wouldn’t think that would be the issue. Motherboard is an ASUS with built sound card. I have had no other issues with editing/recording with Audacity.

The only visible change when a noise profile has been created is the the Preview and OK buttons can be active (not greyed out).
Capturing the noise profile is very quick, and once complete the interface will close (so quick that it may appear to have closed without doing anything.

Getting a noise profile does not change any of the other settings. The other settings are there for “tweaking” the effect once you have captured the noise profile.
See here for a detailed description: http://manual.audacityteam.org/o/man/noise_removal.html

I have some sound files that I got from some old records

It’s not going to help. If you’re trying to suppress the clicks and pops associated with old records, Noise Removal is going to fail. There are other much better tools to clean records.


The formal Noise Removal works by memorizing a continuous noise like air conditioning rumble or computer whine (the Profile step) and then trying to subtract that exact whine from the show. Clicks and pops are not a continuous sound, and so don’t qualify as “noise.”

I know we’re hiding behind a technicality, but there it is.