HowTo Recover Very Old .aup files

I have some old audacity archives which have become very important. I would like to export them to .flac files, but when I attempt to open them with my current version of audacity, I get an error (see below). The archives were created in 2007, using (I think) audacity-2.1.3

My current system is Fedora-34, all upgrades installed
Audacity version 3.0.2 installed from the Fedora distribution

Here are the error messages

An assertion failed
/builddir/build/BUILD/audacity-minsrc-3.0.2/src/Sequence.cpp(1579): assert “coalesce || !result” failed in DoAppend().

with this backtrace:

[1] Sequence::DoAppend(char const*, sampleFormat, unsigned long, bool)
[2] AUPImportFileHandle::AddSamples(wxString const&, wxString const&, sampleCount, sampleFormat, sampleCount, int)
[3] AUPImportFileHandle::Import(WaveTrackFactory*, std::vector<std::vector<std::shared_ptr, std::allocator<std::shared_ptr > >, std::allocator<std::vector<std::shared_ptr, std::allocator<std::shared_ptr > > > >&, Tags*)
[4] Importer::Import(AudacityProject&, wxString const&, WaveTrackFactory*, std::vector<std::vector<std::shared_ptr, std::allocator<std::shared_ptr > >, std::allocator<std::vector<std::shared_ptr, std::allocator<std::shared_ptr > > > >&, Tags*, TranslatableString&)
[5] ProjectFileManager::Import(wxString const&, bool)
[6] ProjectFileManager::OpenFile(wxString const&, bool)
[7] ProjectManager::OpenProject(AudacityProject*, wxString const&, bool)
[8] AudacityApp::MRUOpen(wxString const&)
[9] AudacityApp::SafeMRUOpen(wxString const&)
[10] wxEvtHandler::TryHereOnly(wxEvent&)
[11] wxEvtHandler::ProcessEventLocally(wxEvent&)
[12] wxEvtHandler::ProcessEvent(wxEvent&)
[13] wxEvtHandler::ProcessPendingEvents()
[14] wxApp::DoIdle()
[15] g_main_context_dispatch
[16] g_main_loop_run
[17] gtk_main
[18] wxGUIEventLoop::DoRun()
[19] wxEventLoopBase::Run()
[20] wxAppConsoleBase::MainLoop()
[21] wxEntry(int&, wchar_t**)
[22] main
[23] __libc_start_main
[24] _start

Is Audacity 2.4.2 available for your system? (or any earlier version)?

The project format was changed in Audacity 3.0.0. The previous version was Audacity 2.4.2, which was the last version to natively use the old AUP format. (Audacity 3.x uses an “importer” to import AUP projects into the new AUP3 format).

Thanks very much for your quick reply.

Audacity-2.4.2 is not on my system, nor is it available in the current distros. I have audacity-minsrc-2.1.2 but it is proving difficult to build because of issues with wxWidgets. There appear to be two versions: wxGTK and wxGTK3. Both libraries are on my system, but it’s not clear which one audacity requires. It would be a help

  • To have the source for audacity-2.4.2
  • To know which library (wxGTK or wxGTK3) audacity uses

I’m trying to think of an easy way to get your old AUP files safely exported as audio files.

Possibly the easiest way is if you have access to an old computer that you can more easily install Audacity on.

Failing that, you could perhaps install VirtualBox and create a virtual machine running Xubuntu 20.04 (Xubuntu is relatively light, and Audacity 2.3.3 is available in the standard Ubuntu repository).

No guarantees, but you can try:

git clone -b Audacity-2.4.2 --depth 1

I have built audacity-2.4.2 from the sources at Github, and it has read one of my old .aup files, so it looks like my problem is solved. It would help if the following locations were more prominently posted on the audacity web site, since even you seem to be a little unclear about where they are. I fear that I am not the only person who will have this problem in the future.


Thanks for your help.

I was trying to save you from having to build :wink: but as you’ve got it working I shouldn’t have worried :slight_smile:
Glad to hear it’s solved.

FWIW, source code for all releases since 1.3.14 are available here:
(binaries for Windows / macOS for versions since 3.0.0 are also available, and from 3.0.3 there will be an AppImage for Linux)
In earlier versions the build instructions for Linux are in /linux/build.txt
In versions from 3.0.3, the build instructions (all platforms) are in /