How upsample channel to 11 289 600 hz

Hello from France, first sorry for my bad english. The mail support send me here.

For a scientific purpose i want to upsample some channel in audacity to non usual/classic sample rate like 11 289 600 hz (44,1khz x 256) or more like 1024x
The resampled option in menu allow only upsampling to 384khz, i can’t write value > 384khz.
It’s very important to me to have a modded audacity version or a update who can do what i want, or a command line who an do it in audacity. I not a programmer, but i think this thing is not complicated to do, because Libsox library used in audacity allow all sample rate resampling, I want to resample my audio channel in audacity. No with other application. I know superior sample rate can’t be readed by soundard/programm.

I’am on Mac os 10.10.4 (Yosemite) and use Audacity 2.1.0.

I will be very happy to donate to audacity team if someone help me to do this for me.

11289600 Hz is too high for Audacity.
It is also too high for all sound cards, so even if you could do it, the only way that it could be played would be by down-sampling before passing the data to the sound card.

Could you say more about that? Why do you need to resample to 11289600 Hz sample rate? (perhaps there could be some other approach that you could use).

Is not a problem ! I don’t want to read 32bit/11289600 kHz audio off course and for the quality 24/44.1khz is enough off course !
I just want this in audacity, for some dsp treatment and after dowsampled it back to normal rate.
Audacity can import all sample rate file and can do resampling effect with all sample rate. I already can import a 11289600 Hz file and downsampling it to 44,1, Auda don’t allow upsampling because no sound card can play audio >384 but technically the resampler can resample all signal. I just want upsample properly to non classical sample rate and export.

Its for my student Thesis about digital audio, want to do some measurement. I can’t all tell you fine.

You can do it by typing in 11289600 in Project Rate bottom left of Audacity then Tracks > Mix and Render. You will not see all the sample dots when zoomed in. It looks like you see one in every 100 sample dots in some places and one in every 1000 elsewhere. So you should not trust what you see.

If you only want to export, just change the project rate.


Thanks for your response. I already tried this method. It work, but non perfectly. The processing resampling time is 2x faster when resampling like this than using the resampling option in the menu, more longer time but better. I really want to do resampling use the resampling option. Any solution ?

In what way is resampling using Tracks > Resample… better, or what is wrong with Mix and Render?

If we let you enter 11289600 Hz in the “Resample” dialogue you would not see all the sample dots in Audacity.

Remove the hardcoded maximum of 1000000 Hz in Menus.cpp and recompile Audacity.

You can make this a feature request, too. There are a number of places where there are hard coded sample rate limits, but this upper limit (which is in Set Rate in the Track Dropdown Menu too) might be thought reasonable.


I don’t know, why but i think there a little bug when resampling by export with sample rate project changed.

Per exemple if i upsample 44,kHz to 192khz (“normal” sample rate) , in menu resampling, it take exactly 22 seconds. Do the same think but with changing project rate and do “mix and render” take only 11 second. To my ear with AbX comparaison in blindtest software the file obtain with resampling option in menu sound more smooth (is maybe because longer time processing do the job best)

If i enter 11289600 Hz in the “Resample” menu audacity say me incorrect value.

I’m not programer and i never do code. Remove the hardcoded maximum of 1000000 Hz in Menus.cpp and recompile Audacity is easy for me who has never coding ?

Really thanks you for you support response.

I agree that Tracks > Resample… takes proportionately longer than Tracks > Mix and Render, whatever “High-quality conversion” quality is chosen in Quality Preferences. So that suggests that the Mix and Render isn’t simply selecting a lower quality, whatever the reason is.

That is what it is coded to do.

There is no programming to do. It means you have to remove a few very obvious lines of code in Menus.cpp and recompile Audacity. We have just made it much easier to compile Audacity on recent OS X.


Thanks you really ! :slight_smile: I gonna try to Remove the hardcoded maximum of 1000000 Hz alone. If i need help where i can repost a topic ? Still same forum ?

First, get wxWidgets built, then Audacity built, without making any changes. If you need help doing that, post in the Compiling Audacity board.

If you have built Audacity without changes but cannot see what to change, ask in this topic.


Haha ! I just readed your link. I understand nothing. Ok ! it’s time to learn haha ! i hope i will success :slight_smile: Thanks you for all. Topic close enough I think :slight_smile: