How to use sample data export import

I am using audacity 3.1.3. I can’t get sample data export to work.
I am opening a wav file. Selecting a small part. Tools-> sample data export-> ok
and i get this:
Error The destination folder\sample-data.txt cannot be written. :confused:
What am i doing wrong?

Are you exporting to a folder that you normally have access to? i.e. Your regular documents or music folder?

After opening “Sample Data Export”, click on the “Select a File” button and browse to a folder that you can write to (such as your “Documents” folder). Leave the file name as “sample-data.txt”. Click the “Save” button to close the file browser dialog. Note that this does not actually save anything - it has just selected where the output file will be saved when you run Sample Data Export.

Then set the other parameters as required, and click the OK button to run Sample Data Export.

Ive done that and it prints the same error.
lets go step by step with images. is this correct?
Screenshot (5)_LI.jpg

If you want to be able to re-import the data with “Sample Data Import”, then you need to export in the correct format. See:
(Measurement scale: “Linear”)

It throws the same mistake with linear and with db and with pretty much all combinations. I looked at the examples, copied them to a txt file, tried to import them and again the same error. I wanted to go step by step so you can tell me exactly how you do it and maybe then we could find what is wrong. Does this require some other add on to work, i can’t understand what am i missing. :confused:

Neither do I.

Are you sure that you are logged in to the computer with the same user name as the “Documents” folder that you are trying to save the data to?

I assume that you are running Audacity with normal user permissions and not running it as Administrator?

I deleted audacity redownloaded and reinstalled it. The 32bit installer. I reset all prefs during iinstall and i started clean. Again the same error. I am just opening the audacity exe to run it, i have previously tried to run it as admin to see if that was the issue but it was not.I ve tried save to a different destination but that didn’t work too. It cannot write or read to any txt file. My txt default encoding is utf-8 and i have tried importing txt file with ansi encoding to see if that was the issue but again no. Everything else is working fine except from this thing. I am logged in to the correct user. I painted over it in the screenshot becauce i have named this pc bigpenis and i didn’t wanted to get cencored. :laughing: I am joking. What do you want me to do so that it will help you understand what is the problem? Is there a problem wiith the “sample-data-export.ny-sample-data-import.ny”? Is there a problem with the library that reads and writes to files? I have also tried to save in html, cvs and the rest but no. First of all, am i the only one with this problem?
Do you have a txt file that works so that i can try to import it for testing?

Looks like it.

I’ve just tested with Audacity 3.1.3 on Windows 10 and it works perfectly.

sample-data.txt (1.65 KB)
Note that this is only 100 samples, so you will probably need to zoom in to see it.

I don’t know what’s going on… I’ve only played-around with this but I never had any trouble.

What are your plans for the text file? Maybe there’s another solution…

[u]GoldWave[/u] ($60 after free trial) has a similar feature (File → Save As → File Type = Numerical Text). The text format may be a little different but you can try the free trial. GoldWave doesn’t seem to have a file size limit so you can end-up with a HUGE file, much bigger than a WAV file.

Destination folder\sample-data.txt could not be opened
check that file exists.” :angry:
I don’t know, i give up for today. Thank you for trying to help.

Are you able to export audio files from Audacity to that location?

Round 2. Me vs bug. Lets go! :wink:
Yes steve i can export, record, import different file formats and pretty much everything is working fine. I deleted the audacity folder in application data and reinstalled but that didn’t work. Now i 'll try built it from source to see what happens.

One more thing. In the AppData\Roaming\audacity directory it stores a “lastlog.txt”. I am sending you a screenshot to see if this can help.
Screenshot (7)_LI.jpg
On the left side txt is the lastlog when i am trying to import tha sample-data.txt i got from here and on the right lastlog is when i am trying to export a sample from a wav. I don’t now if this is important but worth the try.

I downloaded audacity legacy 2.0.5 and i can use sample data export just fine. This is getting funnier and funnier. I can’t seem to find sample data import so that i can test that too but the point is that is working. I am starting to suspect what the problem is and it is my stupidity. One moment to check please.

The problem has to be something with permissions to read and write. With the latest version of audacity i can use sample data import-export just fine as long as i put the files in a public username. C:\Users\Public\audacity. If i put it in my username or any username i create it cannot read or write (do the sample data import-export thing). So i am thinking it has something to do with permissions. The weird thing is that legacy audacity 2.0.5 works for my pc. :astonished:
One more question i have is that i noticed when i import data the last 0.02 sec roughly seems changed and sounds distorted.
Screenshot (10).png
I am splitting to mono the sound in the bottom of the screenshot exporting 1sec and importing it. If i delete the last 0.02 sec of the top imported sound it recreates the distorded part in the new last 0.02 sec. Am i doing something wrong?