how to use my interface

Using windows 7 and an M-audio fastback when I go to 'edit" and than select devices and than 'Interface" the only selections I have are MME and windows direct sound, how do get my M-Audi fastrack to come up as an interface. If anyone can help would be greatly appreciated

Thanks you

Contact Information removed by Forum Elf.

I removed your contact information. It’s dangerous to post that on the forum.

Those are just the Windows Systems used to manage sound, not the actual device. You should know that Audacity checks for sound devices when it starts. So plug in the Fast-Track first, let it settle and then start Audacity. You can also Transport > Rescan… at any time.

It should arrive in the Audacity Device Toolbar.

It’s probably not going to say “FastTrack.” It will probably say something odd like USB Audio Codec. That’s it.

Let us know.


You should also know that your device’s long-form family name is Avid M-Audio fastrack. The devices in this family are designed to slide right into an Avid editing suite, room or system. Some of them have a difficult time with plain Windows installations. You may need custom software drivers to get it to work.

Look for the word “ASIO.” That’s a special software driver that many audio devices need. Audacity doesn’t directly support ASIO.


Koz I have the 6.0.6 drivers downloaded, plugged in the M-Audio fast tack a few hours ago and even tried 'Transport>Recscan audio device, nothing is happening, still only show MME and the windows deal. any other thoughts. on what I am doing wrong, sorry to be such a bother

We should wait for an elf who knows how to play Windows better than I do.


Topic moved to Windows forum.

Try rebooting the computer with the interface not connected (or switched off), then connect the device and switch it on.
Wait a few moments for Windows to connect the device, then check in the Windows Sound Control Panel that the device shows up correctly as both a recording and playback device. If you send an audio signal into the device you should see green meters in the control panel responding to the signal.

When you are sure that is working, open Audacity, and in the device toolbar set the “host” to MME and the device should be available in the ‘recording’ and ‘playback’ device settings.

And if that does not help, disconnect and reconnect the device then reboot with it connected: