how to record the 2nd track with vocal only

hi i guess i mess up my setting in audacity my problem is everytime i record a song cover i use mp3 for the first trcak and record my vocal on the second track but the problem is i hear the mp3 on my second track still, it will recorded there too.i hope someone will answer know this ,thank you so much

Which version of Audacity? (Look in “Help menu > About Audacity”)

What sort of mic are you using, and how is it connected to your computer?

What settings are you using in the Device Toolbar?

In the “Transport menu > Transport Options”, ensure that “Overdub” is on (selected) and “Software Playthrough” is off (not selected).

im using the newest version windows of audacity and im also using f8 soundcard withb my bm800 mic i will attach a sample video ,ive been looking the setting but everything im using hiost mme-my mv-ap82x microphone-stereo-mv-ap82x headseat,thank you so much
Screenshot (4).png
Screenshot (3).png
Screenshot (2).png
Screenshot (1).png

Sorry but I find your reply confusing.

What version number does it say in “Help menu > About Audacity”?

Is that the “Zopsc F8 Live Sound Card”, or the “Zoom f8” or some other “f8”?

Is that the “ZINGYOU Bm800”?
Is it battery powered?
Is it USB, mini-jack, or XLR?

What is am “mv-ap82x”?

hi sir sorry my bad ill send again what version and soundcard i use ,and yes you are right sir im using zingyou mic .
Screenshot (9).png
Screenshot (8).jpg

What is the “mv-ap82x”? Is that the driver for the f8 device?

Where are your headphones plugged in?

i plug my mic and headset to my f8 soundcard and i also connect the other point of the wire to the charger of the soundcard and other point which is usb type to the laptop .the mv-ap82x that is the name of my mic or soundcard on the computer for example computer mic ,microsoft intel mic just like that

I think the problem is that the f8 is mixing the USB input from the computer (the audio that is playing) with your live input, so both the live input and the audio playing in Audacity is being recorded.

Unfortunately I’ve not been able to find a manual for the f8, so I don’t know if it is possible to tell the f8 not to do that.

If it’s not possible to stop the f8 from mixing its USB input with the live input, then you may be able to workaround the problem by plugging your headphones into the laptop headphone socket and changing the playback setting in the Device Toolbar accordingly. The disadvantage of doing this is that it will not be possible to monitor your live input through your headphones.

anyways thank you so much for your time sir and answering my message