How to delete the click track after recording vocals?

Hi there,

I know that this question has been asked before and this was the answer: “Change the input source in the Mixer Toolbar dropdown selector to the one you are actually recording from (presumably line-in or microphone according to how you are recording the guitar). What you’re doing at the moment is recording from “stereo mix” (or however the option to record the computer playback is called), hence you are recording everything that you hear.”

1 don’t have a clue as to how to do this or what this means.

When I click x to delete the click track, I can still hear it afterwards. I’d like to send the vocals out to a producer, but having the click track in the recording isn’t going to cut it.

Any help is greatly appreciated.

I’m using a Blue Yeti and have downloaded the most recent version of Audacity.


So, presumably you have “Generated” a click-track. Then you have “Recorded” a second track below it via Shift-Record, by recording through your Blue Yeti microphone.

Now you have deleted the original click-track and it is no longer visible, but you can still hear the click-track when you play your newly recorded track, so you know your recording is damaged.

  1. When you record, be sure you are recording through the Blue Yeti microphone. It should be selected in the Device Control panel’s dropdown list. If you don’t see your microphone in the list, exit and restart Audacity or do Transport > Rescan. Frequently newcomers accidentally record via their built-in microphones. Lightly scratch the microphone to make sure you are recording from the correct one.

  2. Is it possible that you are playing the click-track through your speakers? Your Blue Yeti microphone will pick up sound from your speakers just as it records your voice. Perhaps the best way to avoid this is to wear headphones. Earbuds help a little, but headphones are even more effective, as there is less bleeding.

I hope this helps. :smiley:

Yes, you were correct in what you described that I’m trying to achieve!

Thank you. Your advice definitely gives me a couple of ways to try to resolve this issue.


Almost all good quality voice recording is done with large, sealed headphones.

It’s not only a sound quality or syncing thing. If you listen to your real-time presentation, your voice volume variations and theatrical bumps and emphasis magically go away.

There’s another way to get your backing or rhythm track stuck in your voice. If you like to record iternet music or shows, that recording setup is not the one to use for overdubbing. As jademan above, you have to be recording from something you can reach out and touch like your microphone, sound mixer, or interface. If you find yourself recording from a “software redirection service” then you’re connected to the wrong thing. Some of those services will try to record everything on the computer, everything in this case being your voice and the backing track.

It’s relatively easy to test. Start a recording and watch the Audacity recording bouncing sound meters. They should not bounce until you speak or sing.

Did we cover the overdubbing settings?

Audacity > Edit > Preferences > Recording:

[X] Overdubbing