How to actually install FreeVerb on Ubuntu (SOLVED)


I want to give freeverb a try, and this site appears to be the place to add it to my computer, but to tell the truth I’m a bit sketchy on the commands I’m expected to make.

It’s asking me to run make command in the /src folder, and I’m reasonably sure I’m supposed to do something more than just navigate to /src in the terminal and type make. I feel like there’s more to it than that.

Can anyone help me out with the commands?

I’ve got Ubuntu 12.04 and Audacity 2.0.0

To build an application from its source code you need to have a “build environment” that includes all of the necessary tools for the job. Fortunately, setting up the build environment is not difficult on Linux.

Are you wanting Freeverb specifically for use in Audacity? If so then there is a version of Freeverb specifically for Audacity and I can give step-by-step instructions for how to get that version rather than the CMT version.

Ah, yes, thank you, that’s actually exactly what I want it for. That would be fantastic if you could do that.

I might save learning about build environments for another day if I can get away with it.

Thanks heaps.

No, you’re going to learn about build environments now :smiley:
(don’t worry, it’s pretty easy if we have a specific example to follow :wink:)

The current version of Audacity is 2.0.3, which ships with GVerb (not a great reverb).
The next version of Audacity will be 2.0.4 which will ship with a new Reverb effect, which is an implementation of the “classic” (original) Freeverb effect. Audacity 2.0.4 has not been released yet, but the source code is available and it is quite easy to build Audacity from the source code.

The first thing to do is to uninstall all versions of Audacity that you may have on your system.

Here’s an overview of what we’ll be doing, and then a link to the step-by-step instructions:

The steps involved in building an application from the source code are:

  1. Get the source code
  2. Install all necessary dependencies (including necessary build tools)
  3. Configure and Make the application.

The Audacity source code is managed on-line with a system called “subversion”. The “subversion” system manages the entire source code for all versions of Audacity that have been or will be - it allows developers to add, change and remove code, while maintaining a record of every change. It also allows us to download the current 2.0.4 development version (or any other version should we wish to).

For Debian/Ubuntu and derivative distributions there is a package that includes all of the necessary dependencies and build tools for building Audacity - we will install that.

Actually building the application is (usually) a 3 step process.
First is to configure the build options (the default options should work fine),
and then to “make” the application,
and finally to “install” the application.

OK, so here are the instructions - give a shout if you get stuck:
Just follow steps 1 to 7 in Example compiling the latest Audacity source code on Ubuntu
(remember to remove previous versions of Audacity before you start).

Oh good lord :open_mouth: that looks fun. I can do it I can do it I can do it. I have used SVN before, but it was a graphical tortoiseSVN and we were using it as a file control system for CAD. Not ideal, but I understand the idea.

Ok. So. The page suggested that I try wx-config --version to see if I need to get wx, and I cheated some of the steps of the example and just did sudo apt-get install libwxgtk2.8-dev python-wxgtk2.8 before compiling Audacity. But now I’m going in thinking that basically I don’t have to do that whole page of tricky compiling and configuring of wxgtk. I’m assuming that wxgtk 2.8 is going to be compatible with a future version of Audacity. I always worry when I see two different sets of instructions - where the short simple version seems to contradict the old non-simple version. I think the instructions for the example are nothing to do with me.

Anyway. I got my first big uh-oh. There is no audacity 2.0.4 there in the branches or the trunk. Other pages on the wiki seem to indicate that the trunk version is the latest, which would be 2.0.4. I’m tempted to bail out now and use the PPA: repository but I feel like I’m almost there.

I punched through the lines pretty quickly after that and it all seems to be going ok… at least… it’s doing SOMETHING. And it’s taking a long time doing it. So I have to assume it knows what it’s doing.

HOORAY!!! I did it!!!

It works!!

It’s not called freeverb, or gverb, it’s just called reverb, and you can load presets at the push of a button and they sound fantastic!

Thanks for making me do that :smiley: :smiley: that was actually kind of cool. I did get stuck a few times but worked it all out in the end.

Only thing I have to do now is work out how to add it back to the Applications->Sound and Video menu - but that’s a project for tomorrow night! Good night, and thank you for your help. Cheers! :slight_smile:

edit: oh. uh… so right-clicking on the menu and choosing “edit menus” appeared to do the trick. It just suddenly appeared where it wasn’t before. Don’t know quite how it figured it out, but am not complaining. Job done. Thanks again.

I think that should all be handled by the sudo apt-get build-dep audacity step.
In fact, that step is really useful for users on Debian based systems because it sets up the whole “build environment” thing that we were talking about. It will have installed the gcc compiler, and various other essentials for building applications from source code, which will make things a lot easier if you ever need to build anything else from source code.

“trunk” is the main release branch - that will be the code for 2.0.4 when 2.0.4 is released. Currently it will be built as “Audacity 2.0.4 alpha” (if you look in “Help > About Audacity”).
“trunk” will always give you the latest development version, but you need to be careful with it as there may be unstable/experimental feature in it. Right now the developers are looking to release 2.0.4 quite soon, so the code in “trunk” is in a pretty stable state.

Keep hold of the "audacity-read-only " folder and all its contents. If you want to revert back to the official release version of Audacity at any time you can remove your “svn build” from your computer by running:

sudo make uninstall

from inside the "audacity-read-only " folder.

Congratulations. It wasn’t so hard was it :wink:

You’re welcome.

Oh no!! Something has gone wrong, and I’m hoping you can help me.

Audacity is going fine. But I’m using Hydrogen to create a rhythm track, and importing it to Audacity. I had something go wrong in Hydrogen that happened at some point during the installation now my Hydrogen is sounding like it’s very very clippy and coming out of a terrible broken speaker.

I was having a problem with my audio driver, (either pulse, or jack, I don’t really understand), last night when I first started, but I installed some Jack programs in Software Centre thinking they might help and Hydrogen started working ok, so I figure that maybe Jack had fixed it. Now Hydrogen is sounding bad again, but the exact same .wav file that sounds now terrible in Hydrogen sounds great when I import it into Audacity (where it’s going to get guitars and more drum tracks and then, if I have to, vocals).

I think something that we did last night to fix up Audacity has made Jack stop working in Hydrogen. I apologise for bugging you, I know this is strictly a subsequent issue - but it’s KIND of related to the Audacity install you helped me with last night so I thought you might not mind.

In fact, I’ll post the error message when I run jackd:

brent@Martha:~$ jackd
jackd 0.121.2

JACK is running in realtime mode, but you are not allowed to use realtime scheduling.

Your system has an audio group, but you are not a member of it. Please add yourself to the audio group by executing (as root):
  usermod -a -G audio brent

After applying these changes, please re-login in order for them to take effect.

You don't appear to have a sane system configuration. It is very likely that you encounter xruns. Please apply all the above mentioned changes and start jack again!

Can you help me configure my Jack and/or Alsa and/or pulse so that I can hear things in both Audacity and Hydrogen? My gratefulness would continue.

I think that this is unrelated to Audacity.

You need to be careful when installing, and particularly when removing Jack application.
There are 2 versions of Jack - “Jack” and “Jack 2”. Applications that require Jack will often specify one or the other, though either should work. The problem is that installing or removing an application that requires Jack, “may” cause the installed version of Jack to switch from one version to the other (you can only have one version installed at a time). If the version of Jack changes, then you need to re-set-up Jack Control (assuming that you are using Jack Control (qjackctl) to start/stop and manage Jack.

That is saying that your Jack set-up is wrong.
Try rebooting the computer, and before you run any audio applications, try starting Jack and see if you get the same message. If you do, then this is unrelated to Audacity.

I note near the top of the error message:

Your system has an audio group, but you are not a member of it. Please add yourself to the audio group by executing (as root):
  usermod -a -G audio brent

If that message re-occurs, you will need to add yourself to the “audio” group, and then log out and back in again.

Ok, thanks. I appreciate the information, and all your help. Thanks.

Ubuntu probably has a GUI application for setting “members and groups”, but if not, the command is “usermod”
You will need to use it as “sudo”.
Thus if your user name is “brent”

sudo usermod -a -G audio brent

Excellent. Job done!

Everything checks out ok as of right now. Thanks yet again, you’ve been very kind to me.



Great stuff.
I’ll close this topic and mark it as “solved”.