How do I turn off the Compressor while recording?

I am digitizing live music from cassette tapes. My source is coming from a Soundcraft Notepad (no compressor option) going to a Toshiba Satellite laptop computer (E205-S1904). I am noticing that on the playback, the music is highly compressed and it sounds obvious the processing is set high. I would like to turn off the compressor for a more natural sound. When I export to MP3, the sound is still severely compressed. Is this compression happening while the music is being recorded by Audacity. Please advise. Thank you.

Turn off the Windows sound enhancements (see: “Why do my recordings fade out or sound as if they were made in a tunnel?”

Also make sure to turn Skype or other Chat application and Games off. Really off, not just napping and waiting for a call or pausing between games.