How do I stop Audacity from saving a backup?

You asked this question over two years ago. See How do you turn off saving an old copy of a file? - #6 by darkcyber

The answer is the same as then - Edit > Preferences…, then the Import / Export section and set Audacity to “Make a copy of uncompressed audio files before editing (safer)”.

If you set it to read directly from the original then overwrite the original, Audacity makes the “old” copy so that it still has the original data to work with.