How do I get rid of the hiss in my recording


PFA my sample voice.

I’m using Audacity 2.3.3 on Windows 10 Enterprise x64 with NoiseGator.

My voice is tinged with the hiss.

Please help.


Does Audacity record OK if you don’t use NoiseGator?

We can’t take a correction out of your work. So we have no idea how bad your voice was before you changed it. We need to hear a simple recording.

Without knowing anything else, it sounds like you have a broken microphone. When you post back tell us the microphone you’re using. Part and model numbers are good. Pretend we want to buy exactly what you have.


Hi Steve

Does Audacity record OK if you don’t use NoiseGator?

No it’s not OK. I’ve attached sample voice without noisegator. Even audio with OBS Studio without noisegator is horrible.

Hi Kozikowski,

it sounds like you have a broken microphone

Hmm… I think I might have broken sound card or a problem with Windows OS


  1. The same microphone (Xcess) records fine on my other laptop (HP Pavilion g6).
  2. A second generic microphone (see pic) has the same hiss. Works OK on HP.

Thanks for your time guys.

Xcesss Headphones with Microphone-min.jpg

That’s a stereo recording: the channels are different. They should be identical: dual-mono.
(If you invert one of the channels & mix to mono the buzz disappears).

A TRS-TRRS adapter-plug may be required to make the headset work properly with your new computer.

Hi Trebor,

  1. I’m facing difficulties recording to dual-mono. How do you do that in audacity. (Can’t seem to find a clear explanation)

  2. Regarding inverting one of the channels these are the steps I performed.
    i. Open file in audacity
    ii. select split stereo to mono
    iii. selected the bottom track and inverted it. (good till now)

  3. Now, how do I mix to mono. I selected both mono tracks, goto tracks → mix → mix to mono (greyed out; see pic).
    Is there any other way?
    Cannot Mix to Mono.jpg
    Thanks for your time.

One of the other mix options will do …

use one of the other two mix options.png
I wasn’t suggesting inverting as a cure: it just demonstrates you are inadvertently making a stereo recording.
Your buzz problem (pulses 20ms apart) could be Windows being unable to decide which channel to use & alternating between the two.
IMO you need different headphones or a headphone-plug adapter for your new computer.
noise is pulses every 20ms.png