How correct is Audacity when it automatically adjusts?

How correct is Audacity when it automatically adjusts the audio backwards (I assume to fix for possible lagtime)? I’m a rapper, when I’m rapping I feel like I’m on rhythm and on beat, but when I play it back, it feels off beat somewhat in many cases. Currently (since I had to return my mic) I’m recording using my Lap Top’s inbuilt microphone (HP ProBook 640 G1, running Windows 10), and am using these headphones:

I want to get on beat as precisely as possible, since I focus on internal and compound rhyming to land on each beat perfectly. Thanks :slight_smile:
(And yes I know my audio recording equipment sucks, don’t need to remind me please LOL).
Is there anything I can do to compensate for this or fix it? Or is Audacity precise enough in this and I’m just off beat? Or could it be my headphones not coordinated with mic or whatever?

Also this is my first post here so if I did something wrong please tell me :slight_smile: (I checked the “READ ME” thing at the top of the topic list thing when I first logged in).

Audacity doesn’t automatically adjust for Recording Latency. You have to do that.

The short form is: create a rhythm track, play that back in overdubbing mode into your headphones. Jam the headphones next to your microphone. Compare the two tracks.

Write down the difference and add that to Audacity > Edit > Preferences > Recording: Latency. Repeat.

The long-form setup for overdubbing is here.


Thank you!!! :DDD Appreciate the help! :smiley: Will try it, I will update you on whether it worked or not! :smiley:

The only way it wouldn’t work is if you had an underpowered machine and the correction kept moving. We can’t help you with that.


There is one other odd thing. There’s a difference between overdubbing and Perfect Overdubbing. Perfect Overdubbing is when your own live performance appears perfectly in your headphones in addition to the backing track. As a fuzzy rule, you can’t do that by plugging the headphones into the computer.

If hearing the backing track minus your live voice is OK, then you’re good to go. Some people leave one of the two headphone muffs off to make that easier.


It worked perfectly thank you! :smiley: Adjusted it from 100 milliseconds to 133 and it works perfectly now! :smiley: And thanks for the advice and information! :smiley: Appreciate it!

Like this.
Screen Shot 2017-08-31 at 6.27.50 PM.png
Screen Shot 2017-08-31 at 6.23.56 PM.png