How can I not hear myself when I'm recording?

Firstly, I am very new to this program and I do not know many things about recording, so please try to understand. And my pc is Windows.

I use a USB Condenser mic and headphones to record but there seems to be some lagging while I’m recording. I heard that this is called latency problem (?). I tried fixing the latency thingo but I failed to do so. So I was wondering if I could just not hear myself while I’m recording. I’m pretty sure there’s a way because just until yesterday I couldn’t hear myself while I was recording. But today, there seemed to be a lag. I’ve already tried unboxing (unticking) the Software Playthrough (?). But it still wont work.


Does this USB Condenser Mic have a headphone connection in the base?

That may be about the only way you’re going to make this work. The Audacity Recording Latency correction is set to make your successive layers of overdubbing match each other. You have Machine Latency which is as long as your voice takes to go in to the soundcard and come back out again.

All three methods of overdubbing I wrote about have headphone connections outside the computer.

…to get around this problem.

There may be additional ways to work with this, but I think that’s still a problem.


Thank you for your answer but I’m on a budget and I don’t think it’ll be easy for me to purchase anything. I was wondering if there would be a way to just not hear myself while recording? :slight_smile:

As you correctly deduced, “Software Playthrough” must be off (not selected).
There may also be an option in the Windows Sound Control Panel to “listen to this device” - that option must also be off.

I’m having trouble finding the “listen to this device” option.

I’m not on Windows, so I’m just going on what Google tells me :wink:

Open the Windows Sound Control Panel.
Click the Recording tab, then click Microphone, and then click Properties.

OMG Thank you so much! :smiley:

Has that fixed it?