How can I kill the offer to move the help files?[SOLVED]

I’ve been using Audacity for Windows (under XP Pro SP3) since at least version 1.3 and have just upgraded to 2.0.1.

One of its most annoying “features” is that whenever you click on Help and choose either Quick Help (in browser) or Manual (in browser) it pops up a folder tree asking where you want to move the help file to.

Good luck to you if you let it move the help file, since Audacity will never find it again! (I made that mistake in 1.3.)

The only response that works is to quit out of that folder tree with Escape, Cancel, or X - then the help file comes up in the browser as it should.

Nor does Audacity remember that you don’t want to move the file - it will make you go through this every time.

Can this behavior somehow be stopped?

That subroutine should not be invoked at all, much less every time!

How can I stop Audacity from doing this?

All I need is for some visiting friend to use the program and let it move the help file!

Could you post a screenshot of that message - I’ve never seen that behaviour. On my machine it just opens Help in my web browser.
How did you install Audacity? Did you install to the default location?
Which web browser do you use?

I installed it, using its installer, to its default location.

My default browser is Firefox 14.0.1, but I doubt that makes any difference, since this message comes up before Audacitiy tells the browser to open the file.

This is the only program I’ve ever seen this behavior from - in two versions now.

Here’s the screenshot you asked for:
Audacity Move Help dialog.jpg

How peculiar :confused:

Could you try uninstalling Audacity (completely, all versions that you may have installed)
Then run the 2.0.2 installer and select the option to reset preferences when the screen comes up with that option.
When you next open Audacity you will be asked if you want preferences to be reset - tell it to go ahead and reset them.
Then see if the problem is still there.

Could be caused by having added Copy To and Move To as context menu entries in Windows Explorer.


I uninstalled both 1.3 and 2.0.1 using the Control Panel Add/Remove Programs applet,

Then, for good measure, I searched the registry for all references to Audaciy and deleted them all.

Reinstalled 2.0.1 - there was no question asking to me to reset preferences to default.

The behavior was exactly the same.

Do I need to uninstall 2.0.1 and install 2.0.2?

Tried the uninstall-reinstall advice, which did not help. (At least I’m now running 2.0.2!)

Then I tried the advice relating to the right-click Move To and Copy To power tools. I searched for and found the ClassID for Move To and deleted it from the only place it existed,
HKEY_CLASSES_ROOT AllFilesystemObjects shellex ContextMenuHandlers
(I had tried the to find it in the location that wouldn’t completely disable them, but it wasn’t there at all.)

Once I deleted the MoveTo ClassID, Audacity behaved properly.

(Interestingly, deleting the MoveTo ClassID took out the CopyTo entry also.)

Thanks for the link, Ragnar.