Host says "no midi interface" not CoreMIDI?

Hi, since Friday I’ve been running into the “error opening sound device” error and it’s driving me nuts! i don’t know why cos it was working fine up until then.

I’ve tried a bunch of stuff – uninstalling and reinstalling ; restarting computer ; updating computer. nothing worked. even looking at the audio MIDI system to see if the output / input numbers were the same, they all are.

Then i discovered that MIDI device preferences is meant to say CoreMIDI and mine does not. so i’m guessing that’s what’s up with it?
How can I make it say CoreMIDI in the Edit > Preferences > MIDI Devices (this is what it looks like in the attached screenshot).


Screenshot 2020-10-26 at 22.35.59.png

Testing with the current Audacity 2.4.2 on Catalina; Audacity only shows CoreMIDI if a MIDI device is connected to the computer.

okie dokie, but now i’m further confused as to why i’m getting this error. why do i have no playback and this error? i feel i’ve tried everything and nothing works. :confused: do you have any suggestions? cheers.

edit: “Mac: In Finder, choose Go > Utilities > Audio MIDI In “Audio Devices”, select in turn the required Recording and Playback devices. Set “Format” to the same sample rate, bit-depth and number of recording channels as in Audacity.” from the manual under

all the numbers match up. i even tried changing the numbers in both audacity and audio midi setup and nothing works. i’m at a loss here cos i honestly can’t understand why.

is this incorrect?
Screenshot 2020-10-27 at 10.16.01.png

The “Default Sample Format” in Audacity should normally be set to “32-bit float” regardless of the audio device settings.

There’s a few different errors that are like that, but with subtle differences that can give an indication of where the problem lies. What is the full and complete error message?

Is Audacity enabled in “System Preferences > Security & Privacy > Microphone”?


hi, thanks for replying.i’ve attached the error message. this is what pops up when i press play.

i’ve just looked in the microphone privacy settings like in your attachment. Audacity isn’t listed, but there’s no option to add it? :confused:
Screenshot 2020-10-27 at 11.12.28.png

Which version of Audacity do you have? (look in “Audacity menu > About Audacity”)
Which version of macOS do you have?

Audacity : version 2.4.2

MacOS : Catalina 10.15.7

I updated Mac and unisntalled and reinstalled Audacity yesterday cos Audacity hasn’t been working since Friday in hopes that’d make it work, but it hasn’t.

So you’re saying that it did work before Friday?

yes, i use audacity regularly, but out of the blue on friday it just wouldn’t play back and i got that error message i posted above and i don’t know what to do. :frowning: i hadn’t made any changes to audacity. i only started changing stuff when it didn’t work to try and get it to work.

In case the problem was caused by a setting in Audacity, you can reset most of Audacity’s settings from “Tools menu > Reset Configuration”.

is reset configuration meant to open up a window? i just did tools > reset configuration, and nothing happened (that i could see).

i closed audacity, and reopened it and and it still is giving me the same error.

No. It just makes the interface unresponsive for a second or two.
If main Audacity window had been configured in a non-standard way (for example, non-default toolbar layout), then you would see it change back to the default layout.

In which case the problem is probably not Audacity.
Do you have any other audio apps running, or running in the background?
Do you use Skype / Zoom or similar? If so, ensure they are not running.
Have you installed any new software since Friday?

okie dokie

everything that would use audio is fully closed.

i forgot until just, i did download SINE Player on thursday. but that isn’t enabled in audacity.

i just went to add / remove plugins to check and i’ve now just added it to the disabled list. closed audacity completely, reopened to see if maybe that would work but it didn’t, still getting the same error message on playback. i haven’t downloaded any other software since thursday.

“Help menu > Diagnostics > Audio Device Info”
Wait for the info to appear.
Save the “deviceinfo.txt” somewhere convenient, then upload it with your reply.

here you go :slight_smile:
deviceinfo.txt (1.6 KB)

Try uninstalling SoundFlower.

hi. sorry for delayed reply. i’ve uninstalled soundflower and restarted laptop and opened audacity. i’m still getting the same error message when i press play. :confused:

What is your “Aggregate Device”? Do you need it? Is it being used by anything?

i accidentally made that when i was playing about with the Audio MIDI Setup earlier today to try to fix the error problem.

i’ve deleted it (fully closed and restarted audacity & closed audio midi setup) and re-tried but it still is returning the same error message. :confused: