Horribly distorted sound when playing an mp3 file

OS: Pop!OS (a fork of ubuntu)
Audacity: 2.4.2

Captured some streaming audio using streamripper and tried to play it in audacity. All I hear is a horrible cracking noise, with no hint of the original recording (which is all spoken voice). The mp3 will play everywhere else (mplayer, ocenaudio etc). ffprobe understands the file and it looks like a normal mp3. But it is horribly distorted in audacity 2.4.2

Input #0, mp3, from ‘test.mp3’:
Duration: 00:03:58.99, start: 0.025057, bitrate: 128 kb/s
Stream #0:0: Audio: mp3, 44100 Hz, stereo, fltp, 128 kb/s
encoder : LAME3.99r

Have tried:

  1. Changing the default input bit rate (16,24,32)
  2. Applied a extended import rule for mp3 that applied ffmpeg filter and the mp3 filter

A short sample mp3 file has been attached

Thanks for any help in advance.

Also scanned the attached test.mp3 with mpck (http://checkmate.gissen.nl/download.php):

SUMMARY: test.mp3
version MPEG v1.0
layer 3
bitrate 128000 bps
samplerate 44100 Hz
frames 2740
time 1:11.575
unidentified 0 b (0%)
errors none
result Ok

All is good with the mp3. But audacity mangles it on play and all I hear is noise.

That works fine for me with Audacity 2.4.2 on Ubuntu 18.04.

Does this file import correctly for you? (It’s just a 10 second stereo “chirp” created in Audacity)

It seems to be a problem with the Pop!OS distribution. When I install audacity from its PPA distribution, all works fine. I will let the system 76 folks know.