Hollow sound recording vinyl to single input laptop[SOLVED]

I finally decided to convert all my albums to digital. I’m using Audacity 2.0. I have a good JVC turntable and have attached it to my Windows XP Dell laptop using a pre-amp and running that output into my line-in (microphone jack). That connectivity can surely be criticized, but as a lifelong computer analyst, I’m thinking some setting in Audacity is wrong. Here is what’s happening…

As this thread states, the vocals (mid-range?) are tinny and hollow. HOWEVER, when I record using the built-in, crappy Sound Recorder (sndrec32.exe), the vocals are fine. The overall sound is not as high quality as Audacity, but the vocal/instrumental mix is good. Note I recorded both these simultaneously. (Sound Recorder is not up to the job of doing my album conversion. I’m just using it for this test.)

I’m going to attach the samples (sorry about the MP3 format; the WAV files were too large). I’m only in the A"s in my collection, so they are from Joan Armatrading’s first, self-titled album, about 30 seconds of song #1. The difference is easy to hear when she starts singing about 20 seconds into the cuts.

Any help would be appreciated!

Personally I much prefer the Audacity sample.
The Sound Recorder sample is mono. Listen to the first 5 seconds of each using headphones. The Audacity version starts with an acoustic guitar in your left ear. The Sound Recorder version starts with an acoustic guitar in the middle of your head.

No question, Steve! The Audacity recording is FAR superior. BUT. The issue starts about 20 seconds in when Joan starts singing. In the “simple” Sound Recorder one, her voice is balanced with the guitar, etc. In Audacity, she sounds like she’s in a deep well. And it could be because Sound Recorder is mono. Regardless, I assume I’m missing a setting somewhere. I should not end up with vocals so “lost”!

Download the “Channel Mixer” plug-in from here: http://wiki.audacityteam.org/wiki/Nyquist_Effect_Plug-ins#Channel_Mixer
Extract the contents of the ZIP file into the Audacity Plug-ins folder and restart Audacity.
Try applying the Channel Mixer effect (Effect menu, below the divider) with “Preset = Invert Right”.
Does that make it sound better?

Sounds great now!! I had a hard time realizing this option was to be applied to playback – it did not help how things sounded during the recording process. The good news, I’ve recorder a few other albums prior to this – Allman Brothers and Alan Parsons for example (I’m working alphabetically, remember). There were some hollow-sounding tracks on those, too. Now they can be fixed in the editing process. Thanks for your help!

Moved to a new topic with a relevant title. Please start a new topic unless you are commenting directly on someone else’s issue.

Audacity does not apply effects to recordings (or playback) in real time.

This may be quite a common problem with single input laptops and netbooks/notebooks that have a pseudo-compatible dual microphone and line-in port. I too find that if I record from a line level source into such an input, I need to invert one channel. It still sounds cleaner and clearer using a USB sound card that has a separate line-in input.