High Pitched Whining Whilst Recording

Hi Guys!

Sorry if this is posted in the incorrect thread as I’m quite new to this malarkey.

I have been trying to record videos and as I listen back to them there is a high pitched whining sound which I cannot get rid of for the life of me. I have tried using a different mic, but I get the same result.

I have tried reducing feedback as well as changing USB sockets, I’ve updated my sound card drivers in case that was the problem but I am still getting the same result.

I have attached a file of audio in which you can hear the whining, I just hope someone can help!

I just hope someone can help!

Only in the sense that we know what it is. It’s the USB digital system leaking into the audio. Is this a Yeti, by any chance?

In general, this happens when the maker tries to run the super-sensitive microphone electronics directly from the 5 volts supplied by the computer down the USB cable. The higher-end electronics and MicPres don’t do this.

My Shure X2U, for example, has other problems, but “frying mosquitoes” isn’t one of them.

The stand-alone Mic-Pres like the MBox Mini-2 Mic-Pre and digitizer recommended by ACX don’t do it, either. In general, any USB box that features “48 volt Phantom Power” (in those exact words) isn’t going to do it because they all have internal processing to get rid of it.

As you probably found, Noise Reduction doesn’t do well here because the sound is of the exact pitch as babies screaming on a jet. Ever try to ignore that?

We have the comb filter generator and notch filters to get rid of in Brute Force, but that can leave the show sounding funny because, in fact, there are now pieces of the show missing (and we can’t do it in real time, the other frequent request).

In the face of heavy engineering trying to find a sure-fire solution, the only “get out of jail card” is to rip the device apart. Unless you have a soldering iron and fine selection of hand tools, not likely to happen. If you do have such a selection, post back.

There are posters who have tried multiple computers, multiple cables, etc. etc, and the problem may change, but it never goes away.

Call the store or the maker and complain. We think Yeti has gotten away with it for so long because nobody made a big enough fuss. Everybody thinks it’s their own personal problem and not a bad product.



Found it.



Hi Guys,

Firstly, thanks for the quick replies.

Secondly, the main Mic I use is a headset, which is a OZONE 7HX gaming headset, I tried switching it with my old headset which is a X12 Turtle beach but the problem persisted. Could it be the computer’s power supply?

These systems assume the power in the USB cable, the 5 volts, is pure, clean and well-behaved. It’s never pure, lean and well-behaved. It’s always got some trash running around on it. It originates inside the insanely noisy computer.

Particularly on something small like a headset, there isn’t enough room to put filters or electronics. This is a cousin to the cellphone earsets with the microphone in one wire. They’re convenient, but terrible microphones. Did I say they were convenient? They’re really convenient.

Sometimes you can have ground problems. The shield for the data service inside the USB cable and the ground for the 5 volts is the same wire. Any bad connection anywhere is enough to pile whine on the sound.

Most people don’t understand that the microphone signal has to be boosted up to a thousand times before it can be useful. In its raw state, it has all the robust horsepower of butterfly wings. That booster has to be well behaved and perfect or you can have what you have.

One of the things on that list if you have a laptop, is to see what happens if you cast off shore power and run from batteries for a while. People with grounding problems can get some relief that way.

I don’t do sound that way. I have regular analog microphones plugged into a regular analog sound mixer. From there, either into the sound connection of my Mac, or an analog to digital converter such as the UCA-202.


It’s similar to 1KHz + harmonics interference , however your fundamental frequency is 890Hz, rather than 1000Hz.

The code below , pasted into Nyquist prompt [in Audacity “Effects” menu], removes the worst of the whine …

    (setf s (notch2 s 8000 13))   ; apply 8000KHz notch
    (setf s (notch2 s 4431 13))   ; apply 4431KHz notch
    (let* ((q 13)                 ; set the base Q for the filter
           (freq 890)            ; set base frequency
           ;set the number of iterations
           (iter (truncate (/ *sound-srate* (* 2 freq)))))
      (dotimes (i iter s)         ; start the DO loop
      (setf s (notch2 s (* freq (1+ i)) (* q (1+ i))))))

Notch at 890Hz intervals ++.png

Does that work for you? We’re on the edges of our seats.

It’s similar to 1KHz + harmonics interference , however your fundamental frequency is 890Hz, rather than 1000Hz.

That’s discouraging. That means every filter is a custom, one-off job. Koz

Hey guys,

Copying and pasting that code into the Nyquist prompt hasn’t changed anything by the sound of it, although the sample which you posted sounds so much better!

I’m glad this is getting so much attention!

I’m glad this is getting so much attention!

We’re hoping sooner or later, someone will post that they have a little inexpensive USB adapter that makes the problem go away on all microphones.

What? It could happen.


As Trebor observed that noise is actually quite a bit different from the usual USB data lines interference, particularly with the shifting in pitch that is going on. I suspect it may have a different origin.

After posting the code into Nyquist prompt, you then have to apply Nyquist prompt to the audio as if it was an Effect,
i.e. select the audio you want to process, then apply Nyquist prompt.

If it’s shifting pitch, then the notches aren’t going to work. The news just keeps getting better…


No shifting-pitch within MrSeeb’s audio , but the ratio of the harmonics present changes with time …
MrSeeb's audio.png
Maybe an artefact of Pulse Width Modulation of the power supply ? …

I select the track, giving it a yellow outline, and then go through effect > Nyquist Prompt > C/P the code > then click OK. I’ve also tried highlighting the track and repeating but to no avail. I couldn’t apologise more if I am doing this completely wrong, unfortunately software such as this is not my forte.

Thanks for all the help everyone, it really means alot.

Well. That should have worked…


You can select a track by clicking just above MUTE.


I’ve tried to upload a .mp4 to show me doing it but the attachment adder isn’t happy with that and keeps deleting it, so I’ll give you a detailed run down of what I do. After opening the file, I click just above mute to select the audio track, darkening the selected area, I then go to effect, and click Nyquist Prompt, then copy and paste the text into the blank area. After this I click OK, nothing else and then play back the track and it hasn’t changed. Sorry about the lack of ease on this, I imagine this is getting quite annoying!

I imagine this is getting quite annoying!

Puzzling, more like it. Hang in while we figure out what to do.

“Good” news! It doesn’t work for me, either.

Must be a typo in the code or some other programming damage. We need someone who can read Nyquist to figure it out.


That sounds like you’re doing the right thing …
NB: the whine removal code I posted is specific to the audio you posted. It won’t remove any old whine,
only the whine produced by the particular apparatus you used to make the audio you posted.

I’m using an old copy of Audacity : 2.0.6 , [on Windows]. If you’re using a different version that may explain why it isn’t working for you, i.e. possibly a bug in a later version of Audacity, (if the Nyquist code is being copied & pasted accurately).