High pitched whine/hum.

Hey, sorry that my first post on this forum is a help topic, but I really need help.
There’s a quite annoying whine/hum that goes on in the background of any projects I make, and it’s getting really annoying. I don’t want to do a noise removal, because it makes my voice sound like it’s underwater. This is a very recent development, because a few days ago I could record crystal clear audio.
I can’t provide any sort of readings without help, because I don’t really do recordings all that often…
I’m using a Rockband [Logitech] microphone, Realtek drivers, and I’ve wrapped the cable in electrical tape to see if it was some sort of EMI. No dice. I’ve also used every USB port available in my computer. The mic sometimes DOES record clear audio, but sometimes it doesn’t. The odd part is that when it does record clear audio, it does for an extended period of time, but eventually (unplugging the USB, closing Audacity, restarting my computer) it goes back to recording this humming.

I would appreciate any and all help you guys can afford me. ^^

There are ways around that underwater thing, but you’re right, clearing this up would be good.

The reason you’re unplugging and plugging the USB has nothing whatever to do with data integrity or bit interleaving, hoo, haa, etc. It’s pure and simple the five volts and ground that are used in the analog portions of the microphone also go through that plug. That’s what you’re shielding with the tin foil.

We assume the microphone is the only single thing connected to that socket, right? No hubs?

The microphone turns your voice into reeeealy tiny electrical signals which are then amplified and turned into bits with an analog-to-digital converter. Next time you see “A to D Converter,” that’s what it means. Then the bits go down the USB cable to the computer. Bits are pretty robust. Actually, they’re very robust, so the most likely way to get trash into your show is the five volts, the ground or electrical interference through the air. All analog.

If you have a laptop and the batteries are still up to it, make a recording not connected to shore power (wall plug) at all. Disconnect the network, printer, etc. etc.

If that started working, then reconnect things and try again – starting with the wall plug. It’s possible the power system inside the laptop is starting to run out of moxie (technical term). A stressed power system can start to leak wall power garbage into the five volts. It can also make its own buzz by bad filtering of the computer housekeeping. Most of the computer isn’t going to care, but the almost invisible, delicate voice signals are totally going to care.

Since you can steer the problem by rebooting, I won’t go into all the room problems that can cause this, you already know the problem is computer related.


One way around this is to not use the computer five volts. Run the microphone through a wall-powered USB hub by itself . This is a ‘bottom of the servicing bag’ trick that can also be used to extend a USB cable if you need it to be longer than the usual 6 feet (2M).

We also assuming you’re using the standard 2M USB cable, right? No extensions?


I’m not using a laptop, so how would I fix this? Sorry, I can barely keep up with your explanation for some reason.
Anyways, I just updated my drivers, which included rebooting, and it’s still making the sound.
And yes, there aren’t any hubs, and there aren’t any extensions. The mic goes straight to the port.

One way around this is to not use the computer five volts. Run the microphone through a wall-powered USB hub by itself . This is a ‘bottom of the servicing bag’ trick that can also be used to extend a USB cable if you need it to be longer than the usual 6 feet (2M).

We also assuming you’re using the standard 2M USB cable, right? No extensions?


I wasn’t aware such a thing existed, do you mean a USB hub that you plug into a wall, but then run another male-male USB cable to the computer? Anyways, I don’t have any, and a quick google search turns up $20-$30 hubs, which I don’t really want to spend for right now. Thanks for the help on locating the problem though!
The cable is definitely longer than 6 feet, I don’t know the exact measurement, but I’m guesstimating about 12 feet. I’m not using any extensions–this is just how long the cord is. Is EMI the issue here?
Also, why does my mic work some of the time, but not all of the time? This is a fairly new development here–it only started doing this yesterday, but beforehand it worked perfectly. Nothing was changed since then, except for what I’ve done to try to remedy the problem.

Is EMI the issue here?

Maybe, but that wouldn’t come and go on a whim. When you restart the computer, it has to individually manage each one of the USB ports, so it has to restart the five volts. Sometimes the startup works better than others.

Do you have a radio or music player that takes a 9V battery or maybe multiple AA cells? A similar thing is happening inside the computer. The computer is supplying five volt battery up one of the wires inside the USB cable. It’s also supplying a return pathway called ground. It sounds like you may be slowly losing the cable. Your cable is longer than normal and I bet if you reposition the mic or maybe move it around while you’re using it, the buzz may some and go. I had a 12’ USB cable do this recently. It ran a printer and I had no end of ratty failures and print jobs would not always start. All vanished when I put a new cable in.

USB is not an open-ended cable system. There are some very firm limits on length.

If there any way you can put a replacement cable in long enough to see if it works? Shorter is good. Did a shorter cable come with your printer?


Ah, so that’s what you were saying. I understand that–I just needed it in simpler context I guess.
Anyways, I’ve tried moving my microphone around the room, hopefully to get away from a source of EMI, but it didn’t help. But since it worked before with literally no problem–and since MANY people use this every day, there shouldn’t have been a problem that just arose if it’s due to length.
Anyways, there’s a little box that I figured housed the “A to D” converter, as you said, so I opened it up to see if there were any problems. As it turns out, the USB connection is technically only 8 inches long–it’s soldered to the board, and then a different kind of wire (NOT a usb’s red/white/green/black cabling) goes from the board to the actual mic. I guess instead of the mic iteslf housing an A to D, it’s put here to ease up on weight.
I don’t have a printer, but I guess you meant mic. XD
No, it’s a rockband mic. As in, it’s used for the game rockband–it’s actually a fairly good quality mic, though. But I can’t replace the USB cable without soldering the board, and there is no way in hell I can replace the cable going from the mic to the board.

Yes, I see what the problem is. It’s hard wired and you’re stuck.

I don’t know where to go with this. If I was personally trying to fix this, I’d be “messing with it” now, paying strict attention to anything that could fix it, make it change or make it worse. Any symptom is welcome, either direction.

From billions of years of repair work, it sounds like the protective shield in the cable between the box and the microphone failed. When that happens to a conventional microphone, the presentation starts picking up EMI from lights and motors and it sounds exactly like your sample. Still, I have no idea why restarting the computer should change that.

The other desperation troubleshooting technique is change half of the system. In this case, you would be borrowing your mum’s computer and see if the microphone makes noise there. If it does, then the microphone is bad. If it doesn’t, then there may be something wrong with your computer.

Audacity does nothing to the sound during recording. It puts down whatever the computer supplies to it.

I just got done chasing one erratic, bad connection in a series of external hard drives. It’s been weeks. Isn’t this just the most fun?


And what might those ways be? I am doing recordings using a USB turntable but a microphone in port on a Windows 8.1 machine using Audacity 2.0.5. Out of 8 Albums I have converted to MP#s, 2 have the “Underwater” feature. I have used both the Click Removal and the Noise Removal effects. Can’t find out why some work and others don’t (unless it’s a critique on my musical tastes :laughing: ). ANY suggestion would be appreciated.