i think one of my plug-ins is causing audacity to crash every time, but i don’t know which one or what to do…

this is the crash report:

Process:         Audacity [50780]
Path:            /Applications/Audacity/
Identifier:      net.sourceforge.audacity
Version: (
Code Type:       X86 (Native)
Parent Process:  launchd [99]

Interval Since Last Report:          66 sec
Crashes Since Last Report:           2
Per-App Interval Since Last Report:  33 sec
Per-App Crashes Since Last Report:   2

Date/Time:       2012-04-15 22:18:34.078 -0400
OS Version:      Mac OS X 10.5.8 (9L30)
Report Version:  6
Anonymous UUID:  387F8B2B-9FF6-473C-8BB2-4E432210883E

Exception Codes: KERN_INVALID_ADDRESS at 0x00000000ffffff6c
Crashed Thread:  0

Thread 0 Crashed:
0   ...ple.CoreServices.CarbonCore	0x93883de0 VolFSMount::endbulk(void*) + 14
1   ...ple.CoreServices.CarbonCore	0x93883d79 PBCloseIteratorSync + 109
2   ...ple.CoreServices.CarbonCore	0x93883d09 FSCloseIterator + 23
3   com.RPCX.PredatorFX.component 	0x40b34798 uEditorEntry + 100706
4   com.RPCX.PredatorFX.component 	0x40b0adbc 0x40ad9000 + 204220
5   com.RPCX.PredatorFX.component 	0x40b0b167 APluginEntry + 73
6   ...ple.CoreServices.CarbonCore	0x938a4899 CallComponentDispatch + 29
7   ...ple.CoreServices.CarbonCore	0x938a4879 CallComponentOpen + 43
8   ...ple.CoreServices.CarbonCore	0x938a2f15 OpenAComponent + 449
9   Audacity                      	0x000825f8 AudioUnitEffect::AudioUnitEffect(wxString, ComponentRecord*) + 104
10  Audacity                      	0x00084dbc LoadAudioUnitsOfType(unsigned long) + 156

You can tell Audacity to stop checking plugins at startup.

Audacity > Preferences > Effects > [ ] Enable Effects (deselect).

That will tell you which group of effects is doing it. Then delete half of them and check again. Keep deleting half.

This is the down side to loading thousands of effects into Audacity. Just load the ones you’re likely to use.


That is no use if the user cannot launch Audacity as I am guessing.

It would have been better to include all of the Thread 0 report, but it appears Audio Units are to blame. Force quit Audacity and follow these instructions to disable Audio Units in Audacity in the audacity.cfg settings file: .


Do you think one of the Apple filters is at fault? Fascinating. Koz

I doubt it. The identifier for the offending effect ends with “RPCX.PredatorFX”.

I’d suggest looking for the Predator FX audio unit plugin in either

– Bill

it worked thanks! i just took out the PredatoFX plug-in and it immediately opened up just fine!

It depends what you want to do. That is not an Apple Audio Unit, so if you want to use it in other software you will need to tell the other software where you put it.